summaryrefslogtreecommitdiff
path: root/dev-python/cbor2/cbor2-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/cbor2/cbor2-5.1.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/cbor2/cbor2-5.1.0.ebuild')
-rw-r--r--dev-python/cbor2/cbor2-5.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/cbor2/cbor2-5.1.0.ebuild b/dev-python/cbor2/cbor2-5.1.0.ebuild
new file mode 100644
index 000000000000..0a40842019e6
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPENDS="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest