summaryrefslogtreecommitdiff
path: root/dev-python/cattrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/cattrs
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/cattrs')
-rw-r--r--dev-python/cattrs/Manifest2
-rw-r--r--dev-python/cattrs/cattrs-22.1.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/cattrs/Manifest b/dev-python/cattrs/Manifest
index 4e835862eb79..ec0a7013ecf2 100644
--- a/dev-python/cattrs/Manifest
+++ b/dev-python/cattrs/Manifest
@@ -1,3 +1,5 @@
DIST cattrs-1.10.0.gh.tar.gz 100657 BLAKE2B b0475644bdd31e12dabf7b969e1890932309497e66b45a311e97d56062e99837af11677c24e33c6d1bed6ec2c6373eab6535874115960ed450f52804a6e5d73e SHA512 51cda84d30627f9d0eb6842c45f7c91dd2f3d9a21b1a635ad21d0648d409b576f52e6127392d60bdd1b6a803f8f897f970706b9cc64b703c06387bc85cd3740e
+DIST cattrs-22.1.0.gh.tar.gz 108033 BLAKE2B 823e3ab466fd73385a4aaefb547b3457ee9cd100f38b6778c26bbe3d93e23ed9a00f071d6a5d7626da91e6660e2a8118e70cfa53a5960d550b9038fffec58eef SHA512 db1effb8d632dc3843d38b18bcd439c35d8bae0e4379b075417eaedbc130f6426186c0d299bc5b5d68a7354d7c5e53927ba5e0e989d498841a73237c588febb8
EBUILD cattrs-1.10.0-r1.ebuild 1307 BLAKE2B 7d3aaa43d7f068aae4829d6adf0e704717fa1ed45e5fe6fb1dc96f321c0bb3abe6f0d3c8f90b498f0942554c70013f550e205671cd4fa10bd4735d10f44b070f SHA512 c0f099114f06675582cbd107b75f15481841b95fd17debcd142ca17b32815876c93c14569dd4c8d58f6b280a7b200b20d3d9124ce6fe56515fba38f765c16d32
+EBUILD cattrs-22.1.0.ebuild 1246 BLAKE2B dd68a23ca6c061adf7f0df133b3027dcc3c96caacd3dcd76f55fce2a636b8efda29423b7105d2f5045c5d0ab8818397b960f732a427e44c6d9dc2e6b356f8d0a SHA512 ac21c5dc779ff7fcb33ba923589bec1e1538ce31d30b98c9023dadeaa99a9c52704cc3e5aeb5409ea41b06901b1703b3073a9c8aacd9f946e77a8abf7e7cfec6
MISC metadata.xml 347 BLAKE2B 94165f2a8e62f3dc7e195f872944300ffff5ba23b9a7e6c30c18d61bc469ea8ff9b70e516f854bfc52d55a0fd27daff0df58145e34bfe26dbcde8070b8a22630 SHA512 5bb37b39b9574256358a623cff942a95162f5f9dcb32ddf28bd167504c7619be54488fae10044a5c765291f8fa28a5aa346973365dcca867be0eef4e232a4999
diff --git a/dev-python/cattrs/cattrs-22.1.0.ebuild b/dev-python/cattrs/cattrs-22.1.0.ebuild
new file mode 100644
index 000000000000..333c5d6b2290
--- /dev/null
+++ b/dev-python/cattrs/cattrs-22.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Composable complex class support for attrs and dataclasses"
+HOMEPAGE="
+ https://pypi.org/project/cattrs/
+ https://github.com/python-attrs/cattrs/
+"
+SRC_URI="
+ https://github.com/python-attrs/cattrs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/immutables[${PYTHON_USEDEP}]
+ )
+"
+# test_preconf:
+# dev-python/bson[${PYTHON_USEDEP}]
+# dev-python/msgpack[${PYTHON_USEDEP}]
+# dev-python/orjson[${PYTHON_USEDEP}]
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/tomlkit[${PYTHON_USEDEP}]
+# dev-python/ujson[${PYTHON_USEDEP}]
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--benchmark.*::' \
+ -e '/addopts/d' \
+ -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # unpackaged deps, see above
+ epytest tests --ignore tests/test_preconf.py
+}