summaryrefslogtreecommitdiff
path: root/dev-python/cattrs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-27 00:31:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-27 00:31:42 +0000
commit3d05d0025c6d74a6b677a172283a0b25c4cf4012 (patch)
tree9d9401d94ffee217dfec5a729e7b1fdb7cb897c6 /dev-python/cattrs
parent8d35656b4a4e3a2ad6f87abb36b9fc3987d95a53 (diff)
gentoo auto-resync : 27:03:2025 - 00:31:42
Diffstat (limited to 'dev-python/cattrs')
-rw-r--r--dev-python/cattrs/Manifest2
-rw-r--r--dev-python/cattrs/cattrs-24.1.3.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/cattrs/Manifest b/dev-python/cattrs/Manifest
index e7d408dbaa80..0da070a35028 100644
--- a/dev-python/cattrs/Manifest
+++ b/dev-python/cattrs/Manifest
@@ -1,4 +1,6 @@
AUX cattrs-23.2.4_pre20240627-py313.patch 2699 BLAKE2B d57e952f73f866cb72d29568e58668de378a9b25042250a0a6c3af4b44674367edf13ff7de9c174100a7ecc308456f2785d6a31ad09dc30621d870356f58c694 SHA512 e234afaa0e73d14a5bc4712afe9838f06e7aafe8f1e9660d2ae4b08d450b9e72de6fe2da808a98b80324cad16124ae998f56e26b13c7bbee9e7cd1d1ae2757a6
DIST cattrs-24.1.2.gh.tar.gz 428615 BLAKE2B d6874493083c4a082b319a12bead71d8a147a35019f3b08a7f16c4c982c061b98db71d6e1027215df53efc66c93688cbd6d5cfaaa9a46f9bd1a39893bbbc21ee SHA512 00316c062343a91cb71ba297af7d74798000cd44afca6eb6286278b3340efc27621486336c095e21a0e1701105494d60b72991aa00b8ab9bacf30a47eee877ce
+DIST cattrs-24.1.3.gh.tar.gz 428852 BLAKE2B 3c4e7842886229c56f29d6e98f0a19a374aaeacd97015b729cf8ebc677ffcb0fb7e51efd329200ead1fd1bec16e4f86b18effa17fac2511d008e8d34dfdfdd84 SHA512 1fe1de70c4ab8a5e4da7ab534833f22f02b23b01a14b68186185aa5af9b5260606e5f20365fe103901368602d4a9e3560733a85ec06f601227f1cab3c191b1e4
EBUILD cattrs-24.1.2.ebuild 3156 BLAKE2B 1220af6c975b7186e42362c7214f7bb92009d896df55fbb64556a59aa2f09b36ee6ce7c6400fc1cc52f2e7452dda3035d61b6d65ebb22b9a61c4d4e3af02eecb SHA512 5d0871f96d0d25d84781d1e96f4ba5c773698533cea39bba7cfabf7bdcf12a5e29344e15d6b5276b03d26b0ab917e98e3062233822d8d8a0b310c4b95f1b9e1b
+EBUILD cattrs-24.1.3.ebuild 3164 BLAKE2B 42e626445379d4f198c9ee6c47e411043257c307d468a2412ace1ad7b4a5f88140ba9124541229b5ef988c112cac96314d5a0c374ca3a00608efe8af3d4cd607 SHA512 77b26d08cce4a2d9a7f6b6a91810077a6f350e12f41fec6d54ccd6488abd9b9a5057909822a173c863acf497e492ae4ec13b2244791e912c9878340fa481b3b1
MISC metadata.xml 347 BLAKE2B 94165f2a8e62f3dc7e195f872944300ffff5ba23b9a7e6c30c18d61bc469ea8ff9b70e516f854bfc52d55a0fd27daff0df58145e34bfe26dbcde8070b8a22630 SHA512 5bb37b39b9574256358a623cff942a95162f5f9dcb32ddf28bd167504c7619be54488fae10044a5c765291f8fa28a5aa346973365dcca867be0eef4e232a4999
diff --git a/dev-python/cattrs/cattrs-24.1.3.ebuild b/dev-python/cattrs/cattrs-24.1.3.ebuild
new file mode 100644
index 000000000000..938354e5eecf
--- /dev/null
+++ b/dev-python/cattrs/cattrs-24.1.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Composable complex class support for attrs and dataclasses"
+HOMEPAGE="
+ https://pypi.org/project/cattrs/
+ https://github.com/python-attrs/cattrs/
+"
+SRC_URI="
+ https://github.com/python-attrs/cattrs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/attrs-23.1.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.1.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/cbor2-5.4.6[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.79.4[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.20[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.8[${PYTHON_USEDEP}]
+ >=dev-python/ujson-5.7.0[${PYTHON_USEDEP}]
+ test-rust? (
+ $(python_gen_cond_dep '
+ >=dev-python/orjson-3.9.2[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ )
+"
+
+# xdist can randomly break tests, depending on job count
+# https://bugs.gentoo.org/941429
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/python-attrs/cattrs/pull/543
+ "${FILESDIR}/${PN}-23.2.4_pre20240627-py313.patch"
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # requires msgspec
+ tests/preconf/test_msgspec_cpython.py
+ )
+ local EPYTEST_DESELECT=(
+ # these require msgspec
+ tests/test_preconf.py::test_msgspec_json_unstruct_collection_overrides
+ tests/test_preconf.py::test_msgspec_json_unions
+ tests/test_preconf.py::test_msgspec_json_converter
+
+ # tests need updating for attrs-24*
+ # https://github.com/python-attrs/cattrs/issues/575
+ tests/test_baseconverter.py
+ tests/test_converter.py
+ tests/test_gen_dict.py::test_individual_overrides
+ tests/test_gen_dict.py::test_nodefs_generated_unstructuring_cl
+ tests/test_gen_dict.py::test_unmodified_generated_structuring
+ tests/test_structure_attrs.py::test_structure_simple_from_dict_default
+ )
+
+ if ! has_version "dev-python/orjson[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_preconf.py::test_orjson
+ tests/test_preconf.py::test_orjson_converter
+ tests/test_preconf.py::test_orjson_converter_unstruct_collection_overrides
+ )
+ fi
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/preconf/test_pyyaml.py::test_pyyaml
+ tests/preconf/test_pyyaml.py::test_pyyaml_converter
+ tests/test_converter.py::test_simple_roundtrip
+ tests/test_gen_dict.py::test_unmodified_generated_structuring
+ tests/test_generics.py::test_unstructure_deeply_nested_generics_list
+ tests/test_unstructure_collections.py::test_collection_unstructure_override_mapping
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= tests
+}