summaryrefslogtreecommitdiff
path: root/dev-python/casttube/casttube-0.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /dev-python/casttube/casttube-0.2.1-r1.ebuild
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'dev-python/casttube/casttube-0.2.1-r1.ebuild')
-rw-r--r--dev-python/casttube/casttube-0.2.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/casttube/casttube-0.2.1-r1.ebuild b/dev-python/casttube/casttube-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..e1a51c24ebdc
--- /dev/null
+++ b/dev-python/casttube/casttube-0.2.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="casttube provides a way to interact with the Youtube Chromecast api"
+HOMEPAGE="https://github.com/ur1katz/casttube"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e '/data_files/d' -i setup.py || die
+ distutils-r1_src_prepare
+}