summaryrefslogtreecommitdiff
path: root/dev-python/castellan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/castellan
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/castellan')
-rw-r--r--dev-python/castellan/Manifest6
-rw-r--r--dev-python/castellan/castellan-0.12.0.ebuild41
-rw-r--r--dev-python/castellan/castellan-0.4.0.ebuild30
-rw-r--r--dev-python/castellan/metadata.xml11
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/castellan/Manifest b/dev-python/castellan/Manifest
new file mode 100644
index 000000000000..0f1f675848a7
--- /dev/null
+++ b/dev-python/castellan/Manifest
@@ -0,0 +1,6 @@
+DIST castellan-0.12.0.tar.gz 50497 SHA256 22194a1f2084b939652b28deca0f62312636442b0ab50511aff69a4902cf77d4 SHA512 9fe47f9678dc2528cbca652029263db89b71939e70c4f5fddffd1769271c04bec3cad0a7c29a800b646098b3df89fc064049c4fe3887695fe0b5dd6b3146835a WHIRLPOOL fe5d0e43dee622ae84210b21f68e54ef4988433a420554a925c465fcd0abedcfb2aa3f50be11085565239c56acb373800759ae3684c4bb53aac3914fa04573dc
+DIST castellan-0.4.0.tar.gz 49026 SHA256 2ccefefc2036ed0d6c76d735fb70b813e2a02f7adb7fd57e0640d064dce1c883 SHA512 2ccb2a757810c6ec125dbb8832cd09f918f9fbf84836ff69c79872471c7e4e40bc8030e305336ad9821de7c3b93617d39917387a6ab8f68443fb09d3f74d4dd5 WHIRLPOOL 972ef43c96356b4dfd69a5716aa996c6b0ac4ab54a989f8e38e3036e63043a33148e0e475224cfc9c4d7e2e5f122af476553015fc840b6326f599bd472f2f936
+EBUILD castellan-0.12.0.ebuild 1437 SHA256 077e88ce14d8327831f74fda17ec0e693b246f4567e072631317692b934decf7 SHA512 aa3a0b44173a59d3c44007fe0ad573edc2affd4aeb765eda18bc7d208ef15828a61dca39ff5ad234a4a696cdaf26b45ebce726f15bc494bfca9ced57aac4e76c WHIRLPOOL 74688ff04cd855dc2e92bea4c07a8e23f043d978f5e4fcf4183ddcfb2866eef00d0c8d2a78b05aa12b6eace5cdf6c8c20f8f11e33be1754ce19d93a7dbda9b24
+EBUILD castellan-0.4.0.ebuild 927 SHA256 8e38fe10c11312f3b53ff33a28e229e84d0987608e93823b0920a034bc2a9eb8 SHA512 a7e4cf2a25a51e3b2ddf54a182b229ef441e6c2f5925b62c1efd4a457376cc36c0b8cef52691abe0e113c53913a13a0e649ecc3551ddf8c0ffe2529238a379c1 WHIRLPOOL e00c9790f9f7de3ed317f722ce7edaf170e650e83cddf3b8eb38874ab3a9c6219e9a74df6aab613a3dd17303a83a3054a329be21288d9b70139007ec727e69bf
+MISC ChangeLog 2065 SHA256 a44d9c3a6bbe0b73f5d1de7820d2720d084282d0afce1bea2946edccc6c0d1f7 SHA512 0d0c30e22bd695b36108c9127a8d82d26db3739b9b8a1ce7ed3c4e91cdfa7aec5d02ae836805a72332326525b647487940d001a173ec60270b76f785fc1512f7 WHIRLPOOL 8dbcf4b438e06af138947493c6446da2c62c70935a763374db407b65b01b1f44a133a13d16e001d350727fc72c2c96b6cc6a5e907e97cb57649f545aeae4151a
+MISC metadata.xml 326 SHA256 de8ce15e80767b211d050a84d9740a9daa5181d73ef31993901af1890dc0af98 SHA512 f8d928ab94ac70a7a3c2548b67a6296b8e86b5e239a9c74cc4b1a120f64c1e2e2084612b025e26fa3c02099f543ce156e5419a5f6ea165eff79b2dd77e9a2d66 WHIRLPOOL 35d0587e4523e938864a1994931d900749436334d5d193e483cffba3bcf26d6307321dc5985fd803a456c1527176385174bdc0f8cd63b764a431971ef5252d1c
diff --git a/dev-python/castellan/castellan-0.12.0.ebuild b/dev-python/castellan/castellan-0.12.0.ebuild
new file mode 100644
index 000000000000..b2400c1455a3
--- /dev/null
+++ b/dev-python/castellan/castellan-0.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.6[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/castellan/castellan-0.4.0.ebuild b/dev-python/castellan/castellan-0.4.0.ebuild
new file mode 100644
index 000000000000..aa1c79087c71
--- /dev/null
+++ b/dev-python/castellan/castellan-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=" >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3
+ >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/castellan/metadata.xml b/dev-python/castellan/metadata.xml
new file mode 100644
index 000000000000..c9cdba5de5c2
--- /dev/null
+++ b/dev-python/castellan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">castellan</remote-id>
+ </upstream>
+</pkgmetadata>