summaryrefslogtreecommitdiff
path: root/dev-python/castellan/castellan-0.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-08 21:45:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-08 21:45:04 +0000
commit65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (patch)
tree625754b14ae80ac167d1b150c2314b647cd008e6 /dev-python/castellan/castellan-0.12.2.ebuild
parent5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (diff)
gentoo resync : 08.01.2018
Diffstat (limited to 'dev-python/castellan/castellan-0.12.2.ebuild')
-rw-r--r--dev-python/castellan/castellan-0.12.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/castellan/castellan-0.12.2.ebuild b/dev-python/castellan/castellan-0.12.2.ebuild
new file mode 100644
index 000000000000..cb2b3e5e78b6
--- /dev/null
+++ b/dev-python/castellan/castellan-0.12.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic Key Manager interface for OpenStack"
+HOMEPAGE="https://pypi.python.org/pypi/castellan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.6[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+"