summaryrefslogtreecommitdiff
path: root/dev-python/capturer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
commit867ef65cd897014478ed65034b1ac3f139289a77 (patch)
tree3af9d9e893bca02bb644786f42dfaf2678d6908d /dev-python/capturer
parentf077c725ef746943ec7902350b30ff569f5995ba (diff)
gentoo auto-resync : 08:11:2022 - 15:24:16
Diffstat (limited to 'dev-python/capturer')
-rw-r--r--dev-python/capturer/Manifest1
-rw-r--r--dev-python/capturer/capturer-3.0-r1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/capturer/Manifest b/dev-python/capturer/Manifest
index 78cd5bebfd2b..061401a44d05 100644
--- a/dev-python/capturer/Manifest
+++ b/dev-python/capturer/Manifest
@@ -1,3 +1,4 @@
DIST capturer-3.0.tar.gz 18146 BLAKE2B 345313fa9e58c4e0121c795bd99606f99e46459215ed239da56586da8f8ffab35d97f0bf655258abe9cc45d4abaf7cb0ad2e76054d8c1781be2531ca01b04381 SHA512 3c83c0eade27380304347bdc93df392b2cb84c084e50693993dcca5fd572b8f92d31de43b4a2ddd0a0e8c7eb097629127e86a4860918c507d13b0e2979a04098
+EBUILD capturer-3.0-r1.ebuild 707 BLAKE2B 5a08b4d089defcd5ae008e7309430b45ad715789a25c9c9b33d992d40b409a71657168240f62171db475cb848176598b24396b54178d9b501943279fb8b8345f SHA512 046024c4ffaca7a1a388a0456b9f1ac780dbee305534f6fa994c5191db312f4efe53f21a6c5b205838752781ed2ce7bbcbab109173d741e1c4c24b8e76d7bd75
EBUILD capturer-3.0.ebuild 676 BLAKE2B 4f5673fbcca2f01ded89abba3082ee104990f4ae2542e2bf78c20d758c29e59166e241ad26f4478c077fd624ad824d6b67dde3480e46673684e1af59480e79d0 SHA512 a459024c4864b2f82820e425f1e0bb1558587cffd1ef777e64bb1649abe29547efc09c3b4984c5ab23e859f95c791f0ad0157e19dce2d3878e37075ce1d1a766
MISC metadata.xml 373 BLAKE2B 61cece580c214d12891efe3c8fcf599cff07912940dd5d9c95e7f868e4db2c9873a4a78350aede6b5af36b7a19b856b49f8bf5dce8116485ba758aad9ecc69b8 SHA512 0f8e9e5c7c1075e96f5dbc98a70962e6b6d7ec6f8d064fe3d54f295de673223a839e54efe3504fb3edad8b3402e77be4687382375806f246b7caa83dc825bd34
diff --git a/dev-python/capturer/capturer-3.0-r1.ebuild b/dev-python/capturer/capturer-3.0-r1.ebuild
new file mode 100644
index 000000000000..211c82b9d04f
--- /dev/null
+++ b/dev-python/capturer/capturer-3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.io/en/latest/
+ https://pypi.org/project/capturer/
+ https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ epytest ${PN}/tests.py
+}