summaryrefslogtreecommitdiff
path: root/dev-python/calver/calver-2025.4.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-18 08:46:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-18 08:46:05 +0100
commitcf1a411e806b434c96329401a6ff0901ec7f0d5c (patch)
tree969527fcceb3b686400c73b5ed22c1d587a8eb3e /dev-python/calver/calver-2025.4.17.ebuild
parent6a01345ec5dc673d0ebd4653ceb063eafa7fcf65 (diff)
gentoo auto-resync : 18:04:2025 - 08:46:04HEADmaster
Diffstat (limited to 'dev-python/calver/calver-2025.4.17.ebuild')
-rw-r--r--dev-python/calver/calver-2025.4.17.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/calver/calver-2025.4.17.ebuild b/dev-python/calver/calver-2025.4.17.ebuild
new file mode 100644
index 000000000000..02e15c62d5da
--- /dev/null
+++ b/dev-python/calver/calver-2025.4.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Setuptools extension for CalVer package versions"
+HOMEPAGE="
+ https://github.com/di/calver/
+ https://pypi.org/project/calver/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ >=dev-python/setuptools-77.0.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest