summaryrefslogtreecommitdiff
path: root/dev-python/calver/calver-2021.7.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/calver/calver-2021.7.30.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/calver/calver-2021.7.30.ebuild')
-rw-r--r--dev-python/calver/calver-2021.7.30.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/calver/calver-2021.7.30.ebuild b/dev-python/calver/calver-2021.7.30.ebuild
new file mode 100644
index 000000000000..ee5748e2277a
--- /dev/null
+++ b/dev-python/calver/calver-2021.7.30.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools extension for CalVer package versions"
+HOMEPAGE="
+ https://github.com/di/calver/
+ https://pypi.org/project/calver/
+"
+SRC_URI="
+ https://github.com/di/calver/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # bootstrap workaround, until https://github.com/di/calver/pull/8
+ # is merged
+ cat > setup.cfg <<-EOF
+ [metadata]
+ version = ${PV}
+ EOF
+}