summaryrefslogtreecommitdiff
path: root/dev-python/caldav
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
commit66520d3148e31806a52cf7df5b8d91d5cd431670 (patch)
tree15d0c80d9ee1b1e2a454a9930a03e3d3b7c6cc61 /dev-python/caldav
parent0e82736d0df44565875b055019ded1be0ac5c319 (diff)
gentoo auto-resync : 17:01:2023 - 07:14:19
Diffstat (limited to 'dev-python/caldav')
-rw-r--r--dev-python/caldav/Manifest2
-rw-r--r--dev-python/caldav/caldav-1.0.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 98a6f577c80f..6f8d6fd9ab9b 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1,3 +1,5 @@
DIST caldav-0.11.0.gh.tar.gz 126186 BLAKE2B 0d818ea5e76b88b3ea18f1fd878a297fa88ad9921d994a61d05c02aa80b73ac40bd8cb36810a050d8f6a87009911655b64a8a4ef09133cb751a225adacdd5575 SHA512 761753fa86e2ba9788030df1af482177bd01ee266a7fe8da744ac85eee95a74d1450e1afa0f64109b9c12aaedba0354d76da2ee9b27dec2771141fc453727d4f
+DIST caldav-1.0.1.gh.tar.gz 133071 BLAKE2B d7b9eb8015782bed5d32b7c34508cfcc1334d33cdfed99003cf45893b0a894d5a3187a2c98f886f97ffe8a64140a5a3826e1b3f57b58228a61d1ad4f9bf9f72a SHA512 ac816afd74f6fe34d82345a8b3a934fbe2c37af6a75cc8ef91cd87c8b8d147962ff05e701cd91480c1963d57967898129f923655d366820b689959b00f55659f
EBUILD caldav-0.11.0.ebuild 1295 BLAKE2B 2ec17dd0724849ccb44ffbf34389c6503db72f8b4c059781e8dea14dd6affd4f6eeb56aadd795e720fb2537ef6489e6da1d17570ae2259acaa8046a44788d446 SHA512 7506ba748635ea11b80182adb6ed2c5c10693baf49fa7294cab2836f1b9c4c76565a45ffbd14b7d903e938d0b03cacd26c8f0055336660d758698234a79d3779
+EBUILD caldav-1.0.1.ebuild 1345 BLAKE2B 1fb820c1cb3691d568ff6e272cbd18c9e31dd3267b21ac4f695a0cee78d83a4da2e4e44b987408668a7100765e90a63d13e8f7eceddfcee232fc061cfe80a7f5 SHA512 1a3d4db29a029593e3bf6cd24c7441bbd0c72870c6433f5052c8697f9ab984bd651ed718b0531f46583182418f2d244c253823d955cd8821d4ac75dc763ea29b
MISC metadata.xml 394 BLAKE2B f0b9c600418cbbc4c935d53b63f4e6c1235500984ed388ceb26c6e02fdb7200eec1464d8c4af17e6afdf3688479f0a0763e6e710f916c1c71dab2ca84df9509f SHA512 4f94039805c6cbfb97a667d555af39bcce7f10db8a7c61f3b8b48a903fcd52d3e30467c91c9ec13195be6dc3c4ccbfa088aeac390d5e1c64e9267527a8b77b6b
diff --git a/dev-python/caldav/caldav-1.0.1.ebuild b/dev-python/caldav/caldav-1.0.1.ebuild
new file mode 100644
index 000000000000..ebdd830441f3
--- /dev/null
+++ b/dev-python/caldav/caldav-1.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: needs unpackaged recurring_ical_events
+ tests/test_caldav.py::TestLocalRadicale::testTodoDatesearch
+ tests/test_caldav.py::TestLocalRadicale::testRecurringDateSearch
+ tests/test_caldav_unit.py::TestExpandRRule::testZero
+ tests/test_caldav_unit.py::TestExpandRRule::testOne
+ tests/test_caldav_unit.py::TestExpandRRule::testThree
+ tests/test_caldav_unit.py::TestExpandRRule::testSplit
+ tests/test_caldav_unit.py::TestExpandRRule::test241
+)