summaryrefslogtreecommitdiff
path: root/dev-python/cachetools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
commitc78477d222e1ceb9516a9bbbadbba0b5c1ce11db (patch)
tree5187cbad4740387edb2c1cca0942036a0fdccd88 /dev-python/cachetools
parent564687d289b862b8b079569a45a2d39d7b8c3585 (diff)
gentoo auto-resync : 23:01:2025 - 06:45:02
Diffstat (limited to 'dev-python/cachetools')
-rw-r--r--dev-python/cachetools/Manifest2
-rw-r--r--dev-python/cachetools/cachetools-5.5.1.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/cachetools/Manifest b/dev-python/cachetools/Manifest
index 468c9ae2c47d..88aaecf4e293 100644
--- a/dev-python/cachetools/Manifest
+++ b/dev-python/cachetools/Manifest
@@ -1,3 +1,5 @@
DIST cachetools-5.5.0.tar.gz 27661 BLAKE2B b46cdaeb2e2589eecedd2add633d92901be317120f70fbc04b6f552ce87d0cad9fe8e1e561e96a7f76d3617b02f5e02c0a1162a6a267f1ba6a8dbb283e7d8585 SHA512 fac6516880b83e0722e52037bed66c9a2b7ed683ccabca953ab82a27c47ae85a76a8abdc35e584c2c46ed194c1fbb8e3e5d6680235e0c4450d89a95c46904f51
+DIST cachetools-5.5.1.tar.gz 28044 BLAKE2B a670460a89af39f636b7dd9b0e963edff930440c9104474c169504a7cb22de1757b7739e9e8d349a96657d3531c56694cfb91d8c8b33880aef17485a8098c37e SHA512 2709dfb1e937c7b1a232466856817ae74623940219e00ec6ddf2450c70f5fc0597faa0b1f0e10387b3668e939d6e3afa3b983879b51111904ff06f4fb9a693fc
EBUILD cachetools-5.5.0.ebuild 504 BLAKE2B 68bfb3afcc882f31b62212d864a95c79a52af004d8a0bd19bf3995aecccb263c3ccb04befbdcc7effa46063f48fb2b23a75dcc2c9c2ad2817a0a14a966d4d9b6 SHA512 7c8d0e898f45916b42805caa651bd3ade5107604f82dba00c7dbca23d5c54164e182e835c981b238f007aa0a6bd7cf0cc7c05209f9c81d4b007053cd5cb25540
+EBUILD cachetools-5.5.1.ebuild 512 BLAKE2B 3d8670ac7fc38fad5253ad57a9f321f96da7c6b68d1a11731f9d877bfb2620609d1750ad5c32bbf7a7fce203daeee562ce64a7cda912486e4c9a9f352bfdb224 SHA512 d3ad71c96c12882b8308d0304d59ce124a2401fc262fd0a8026cc0d0f8078d0500b4b38093ca85fc511d817823459e741781ed2fe0ead0c638c55685b498d83b
MISC metadata.xml 508 BLAKE2B 46dd3d86627746b2b26d9980c2773a25cde3fe6d8ef25bffd88edf1cd2f66a9457f09eea791efc1dab3d354f405bf755992e4a44acd721e4e72f085eabf9b61e SHA512 63d48b1e710965f09538e71b982df8e2fdf5693c6043d5498e4536f76e139584f8783479c1742f91fbe45b4e7bf9eec8d8a54d698734c196bbd8d5a14712b59b
diff --git a/dev-python/cachetools/cachetools-5.5.1.ebuild b/dev-python/cachetools/cachetools-5.5.1.ebuild
new file mode 100644
index 000000000000..42c2b7871ee1
--- /dev/null
+++ b/dev-python/cachetools/cachetools-5.5.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensible memoizing collections and decorators"
+HOMEPAGE="
+ https://github.com/tkem/cachetools/
+ https://pypi.org/project/cachetools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest