summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-01 11:41:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-01 11:41:16 +0000
commitfd1824e9b1fd180f410170bf2d02e1f098f53db9 (patch)
tree7d1346df7be9d29e8e8b2d7bd8c36fe016fd917a /dev-python/build
parent895ff0a4d41ed3004a73b7869773a26f463c5ded (diff)
gentoo auto-resync : 01:03:2024 - 11:41:16
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest2
-rw-r--r--dev-python/build/build-1.1.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index dbed73ba776b..3e5889fbbcc6 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,4 +1,6 @@
AUX build-1.0.3-setuptools-69.patch 3954 BLAKE2B 7c62fb1deb7cce42de31bd66a0aeea9f6393c8d52406d94056fc8b820488573134f7246eec906a6666cd6178f06cca68bfbc6e3ad831c568eba3f909aaac108e SHA512 2d07f6796a3673ce301a93967cc1b681ff80b143ea11f4bae3a0c96740d1911d68aa0d400ea4d4af6d32819bf4c4bcc3213c7d3bbe48755fbd9534c84b491657
DIST build-1.0.3.gh.tar.gz 43412 BLAKE2B cb707b21582a1f7a5f649dcaf0fa7d30d253641a51c6af1284b17df46ad877af5280b5d1a07ce7eb90ef468d0f850e3e85dba1f24f7942c6ba432789760ae670 SHA512 c2c67ccf407bb1780c90e02bbc2692b8b10cfe441f445c05d38a675f3498d1d6f94306dcbe270c181e14471f1dd3712e2cba33a4792f6140e2e9f0aa3c8e7b81
+DIST build-1.1.1.gh.tar.gz 44605 BLAKE2B aa1d554d55007e8cb715981938bb8765230ae5ddc6c5bc29efeb52c0e18b6337a13c27f3389772a83cc0ecc9b7d3e889fbc305e91f1290424d7031a1782f683f SHA512 5fa64b07f2c22faca074d1447f5fcb12b7ad40e5fe897f034901d7932d8a9aa2c1dfa806d373503246255d7d9a2429b336384a980376f4ae7c810ae275b735da
EBUILD build-1.0.3.ebuild 1759 BLAKE2B 54ff42e04a8eb6f5faf2d234e1ecd68b9b66ba01910a19374a9bab73b0611acd1728ade87f324e036ba5acb614913f50460566260ed2858ff748076ed9755c8d SHA512 7deff279ef23a18875aa195babf3a614f1396b367ef5f4bb39ecfd6486bf9f148d77112231c2aa949d60f1fb21fb317ba59e6d1863c1cd3b7f2602dd7a8ca3c6
+EBUILD build-1.1.1.ebuild 1692 BLAKE2B 4121a1d7b8823a9aac3a8e82591c7d4c46312a943bc3feabfe5b3e395022e20d1b8e4e46237363dbddf81aa28721b38006e205555e63227376077aaffacd9047 SHA512 d26e270a0325cd9a64e218ea3e5bcc9957138391d8b4ac7d5beaa0da9f304d1c0ef2b7536f8bac1917c49d4e2d4594f23a44ccf67100a808177b5e5597d6e5ee
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-1.1.1.ebuild b/dev-python/build/build-1.1.1.ebuild
new file mode 100644
index 000000000000..8e4ef69d1c04
--- /dev/null
+++ b/dev-python/build/build-1.1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, correct PEP517 package builder"
+HOMEPAGE="
+ https://pypi.org/project/build/
+ https://github.com/pypa/build/
+"
+SRC_URI="
+ https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.34[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by the presence of flit_core
+ tests/test_util.py::test_wheel_metadata_isolation
+ # broken by the presence of virtualenv (it changes the error
+ # messages, sic!)
+ 'tests/test_main.py::test_output[via-sdist-isolation]'
+ 'tests/test_main.py::test_output[wheel-direct-isolation]'
+ # broken when built in not normal tty on coloring
+ tests/test_main.py::test_colors
+ 'tests/test_main.py::test_output_env_subprocess_error[color]'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network" -p pytest_mock -p rerunfailures
+}