summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-12 11:46:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-12 11:46:20 +0000
commitaf42afeb201514cfc34a8a056def3389af35a54b (patch)
treedc183d93580761fd7e856068e25c046c6a53396d /dev-python/build
parent26c687603afd123f35f1b8745cb38493a4e7d928 (diff)
gentoo auto-resync : 12:01:2023 - 11:46:19
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest2
-rw-r--r--dev-python/build/build-0.10.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index a45620bd4b24..bfb17d2a5650 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,3 +1,5 @@
+DIST build-0.10.0.gh.tar.gz 41509 BLAKE2B 0b1967af6fd0e47e8de5a6efcab879a37231b399965c4b52d9f952ed4fd64e9606b40f8e34ca18fb634ac5b42e3fa63995e6da292b10424f5ea0bd9fd49a46ca SHA512 e7ab783cc2b228e49c3dd15be7e25150924f26611994367b145cc2d43d7f89597c018cd4ca5cd8b31280d965421d314c80e4b97cf3e00f6cf73d80a3b081e7d1
DIST build-0.9.0.gh.tar.gz 41012 BLAKE2B 764338ffab3b6ede66542195271b1b07d1cff71685ae88bcef8042ce0a93a3a95a80a8a2273ac6a1534d8416410c8af77fdd3fe52fdacb47b8a56a9857ba60a2 SHA512 d6ef229c8f3b348cc939af6bd9a0a521a25c3a5702a95da8ee36d7a1ad3f3e22e10b5c96495ff08a1328ab73f03feebc64e89ce165862cb295eff4360c79d642
+EBUILD build-0.10.0.ebuild 1711 BLAKE2B 0920eafc7950f33cd23d71f2da0eb685f0e7eb87891e0b86efe4b760839a3b85fd5cb0fbc70c4f4598643c311f21cf42cec093109b2a99543b8423307698defc SHA512 b091f33f60e95853ff59c4b1e8a50eb7e23825bc73fd9f533dfabe4561e76f0f4c6417b613615eb1301ace06ed4100bb29fe8c798fb24ab7be1bb321c4eaef9a
EBUILD build-0.9.0.ebuild 2101 BLAKE2B 41059b2880d4716241cacbd696645111fc7bd1374541589c0253322f24afe3405424bc765cc86b81125e84de1dba7f9d2f44117f0d536a0848be8250d8122b5d SHA512 d5ec900c7ca060e6cca0abc8451e5d2336f58f08f0a3aeb1e28cdde1a4c099e3dc4c31fc8ab0bd203ccdc095e9e6f284f368f9a82f16da298d8f95ad99b532c3
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-0.10.0.ebuild b/dev-python/build/build-0.10.0.ebuild
new file mode 100644
index 000000000000..840c30d10816
--- /dev/null
+++ b/dev-python/build/build-0.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="A simple, correct PEP517 package builder"
+HOMEPAGE="
+ https://pypi.org/project/build/
+ https://github.com/pypa/build/
+"
+SRC_URI="
+ https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64"
+
+RDEPEND="
+ >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.34[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by the presence of flit_core
+ tests/test_util.py::test_wheel_metadata_isolation
+ # broken by the presence of virtualenv (it changes the error
+ # messages, sic!)
+ 'tests/test_main.py::test_output[via-sdist-isolation]'
+ 'tests/test_main.py::test_output[wheel-direct-isolation]'
+ # Internet
+ tests/test_main.py::test_build_package
+ tests/test_main.py::test_build_package_via_sdist
+ tests/test_self_packaging.py::test_build_sdist
+ tests/test_self_packaging.py::test_build_wheel
+ 'tests/test_util.py::test_wheel_metadata[True]'
+ tests/test_util.py::test_with_get_requires
+ )
+
+ epytest -p no:flaky -n "$(makeopts_jobs)"
+}