summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 21:06:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 21:06:57 +0100
commit633591ecdf876d163972f90145c0ca61e6c496fa (patch)
treeeea30095f404cb1497898ea66b7a9a182875bb35 /dev-python/build
parentc8ac16ee4e3813ee30a3224cd92efc19477070b0 (diff)
gentoo auto-resync : 25:05:2023 - 21:06:56
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest2
-rw-r--r--dev-python/build/build-0.10.0.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 4ed4bf13281a..a1655414ca9e 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,3 +1,3 @@
DIST build-0.10.0.gh.tar.gz 41509 BLAKE2B 0b1967af6fd0e47e8de5a6efcab879a37231b399965c4b52d9f952ed4fd64e9606b40f8e34ca18fb634ac5b42e3fa63995e6da292b10424f5ea0bd9fd49a46ca SHA512 e7ab783cc2b228e49c3dd15be7e25150924f26611994367b145cc2d43d7f89597c018cd4ca5cd8b31280d965421d314c80e4b97cf3e00f6cf73d80a3b081e7d1
-EBUILD build-0.10.0.ebuild 1940 BLAKE2B 9104f2e9a030356e99fca90736ea8968af880af8f634c060d9aba53682c9a1f0d8538d2398a1ddd07bb73ae4c6b5304f314f15acc8377eb39e2340723ccee6d4 SHA512 3ea72c751c18ff42b49a1a0958f80c1c953506af3e045682e8964aaea54150edc3852c6c9a7552a2efcd469ad158cb79b0ff04f41412fe03c770f8e6a641a7ef
+EBUILD build-0.10.0.ebuild 2110 BLAKE2B adbeec5ad2ac407f321f0049f59015443ef05e852b5f0c9e2212111b16a49f9ee05d3f86f5b2b6b0fe574a2715a03404eb180929e95ca259a183e18d1d7231d1 SHA512 38d747d180c8bd6e7c986671c630ced97e51d16a0ac96cbfc911c312add7512737ae38a3e3f9aa8254b64f44be151bcb03ad87b642310edf589c4c840fc442fa
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-0.10.0.ebuild b/dev-python/build/build-0.10.0.ebuild
index be77518c47ad..6b1865d43115 100644
--- a/dev-python/build/build-0.10.0.ebuild
+++ b/dev-python/build/build-0.10.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 multiprocessing
@@ -60,6 +60,12 @@ python_test() {
# (requires dev-python/toml that we'd like to lastrite eventually)
tests/test_projectbuilder.py::test_toml_instead_of_tomli
)
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # mismatch on deprecation warning
+ 'tests/test_main.py::test_output[via-sdist-no-isolation]'
+ )
+ fi
epytest -p no:flaky -n "$(makeopts_jobs)"
}