summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
commit15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (patch)
tree6da8c6fe191bb632a2a6454968d2d1cc1338a5dc /dev-python/build
parentec82846d15c127f36a0f0620e30c9c0fbbdd514c (diff)
gentoo auto-resync : 02:09:2023 - 10:15:56
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest2
-rw-r--r--dev-python/build/build-1.0.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 4272deefa1af..eb6abdc5a841 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,3 +1,5 @@
DIST build-0.10.0.gh.tar.gz 41509 BLAKE2B 0b1967af6fd0e47e8de5a6efcab879a37231b399965c4b52d9f952ed4fd64e9606b40f8e34ca18fb634ac5b42e3fa63995e6da292b10424f5ea0bd9fd49a46ca SHA512 e7ab783cc2b228e49c3dd15be7e25150924f26611994367b145cc2d43d7f89597c018cd4ca5cd8b31280d965421d314c80e4b97cf3e00f6cf73d80a3b081e7d1
+DIST build-1.0.0.gh.tar.gz 43246 BLAKE2B c26c664cd627a0a070c71cb230b682526ff0f291a620edb402a797eb2baf4ab3e2d32f228241d4e495ee517b60873bb8a7086ea55e3270502a5cd3b650000a79 SHA512 4aac1e9c0402163ce50b4054d9b383cb86f20cda21e09c859ec106c7333a77bc01295371df438f3c04176799b9a57d0501ebf1a01461ad372ceef710120e08f1
EBUILD build-0.10.0.ebuild 2117 BLAKE2B d204f7c4ca4efbdb5ee444b43633a01099982e07111c445091ae78d721cae728c94d3546e485bc8df3822cc75700b2a2765b395d7bd8ab626ea72bf004e6ed0f SHA512 a241af073d82a5fb98a34ea4372c658eb04bab556a3fdc6ed40021576ad48389ef6dc671cc7f460cb8db969a7deedf8b8e0244ef69604bbefc869b8ea6021408
+EBUILD build-1.0.0.ebuild 1516 BLAKE2B c794b9da972e1e44b92434007233c3a2dd4a2120ea2327b66ffb5b6a0f5a31972e53b2e4dbeae4d27f5d3a97ef535560c72ff1f49ad632bbae2e8861c88b8bbe SHA512 f90fd9c2175629e21abcf0868993f20e1b182f59fd53f03da40e327af0fb71299908161d241fa10d8309a29e415b3738770a2d0667feabd297d1bbfbb043874d
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-1.0.0.ebuild b/dev-python/build/build-1.0.0.ebuild
new file mode 100644
index 000000000000..b0fb7340096b
--- /dev/null
+++ b/dev-python/build/build-1.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="A simple, correct PEP517 package builder"
+HOMEPAGE="
+ https://pypi.org/project/build/
+ https://github.com/pypa/build/
+"
+SRC_URI="
+ https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.34[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by the presence of flit_core
+ tests/test_util.py::test_wheel_metadata_isolation
+ # broken by the presence of virtualenv (it changes the error
+ # messages, sic!)
+ 'tests/test_main.py::test_output[via-sdist-isolation]'
+ 'tests/test_main.py::test_output[wheel-direct-isolation]'
+ )
+
+ epytest -m "not network" -p no:flaky \
+ -n "$(makeopts_jobs)" --dist=worksteal
+}