summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/build
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest5
-rw-r--r--dev-python/build/build-0.7.0.ebuild55
-rw-r--r--dev-python/build/build-0.8.0.ebuild (renamed from dev-python/build/build-0.7.0-r1.ebuild)15
3 files changed, 11 insertions, 64 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 0559be9f0b57..84dbe8339b6a 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,4 +1,3 @@
-DIST build-0.7.0.gh.tar.gz 37127 BLAKE2B b06ba16c154087046bd5efddb5fd6f60dad9ee79a204a0c1124fb4885d3692bcf4bd88b75c9665ade3f8457e12742d32e3cef40a0ffb5a894b049a6e942c09e3 SHA512 fd8410dc91333ba94c5141dd78f8052b66f947839752a5d0f401630f6bceed5be2e1f45eceaa2a98908c0e3ddb88a00e3ccca341a3890fa99202bc560ab6ff42
-EBUILD build-0.7.0-r1.ebuild 1954 BLAKE2B 58a291960cfe8aa133c3817c87f2de2fc2e08057bd34bbafc8485dadc55e063c1b83aa3461bdb8751c39b3bf2b601b130409a3cfc37e3ef68a6b04c6009d2fcf SHA512 87766068ccf69c4c4f6028c69ea1c79ed1243eaf73de570ad9ec9f852e34b76156a85d6c8ff2399cf6366e92e553737f13a2717d75d420fe4a73d529a174634c
-EBUILD build-0.7.0.ebuild 1727 BLAKE2B d8cdba74a33db197a2901a906ed81f891eaaf9c79706395fc5a8955528681ff3e77be3ea223c5f492511feaf6319406440b10b99db2f1927e3af2e7043c647b2 SHA512 f713734516587727f3874ccb6d0d1042cd84fde5adc0989963ca70858a819785fcc9a4ee3b84c3536ad10a969d4a2606b58ee714c2e3bf915f792276c71942b7
+DIST build-0.8.0.gh.tar.gz 40020 BLAKE2B 17422c8fe23d4103c78bd9d98702646f0863abfea4ff5df425942eb71aa905d8171567976228681afa90f453131ccce4701128b4f73b61acf4158ea2758c5c9e SHA512 62eaabef36fae592b06c41623f8f36750a029263a65c8fa21ad58b24ef30d4fa8eef7588237a68efb9a9784676f35605a8c9a6b2ed1bc6844c32924f9b5ec377
+EBUILD build-0.8.0.ebuild 2101 BLAKE2B 41059b2880d4716241cacbd696645111fc7bd1374541589c0253322f24afe3405424bc765cc86b81125e84de1dba7f9d2f44117f0d536a0848be8250d8122b5d SHA512 d5ec900c7ca060e6cca0abc8451e5d2336f58f08f0a3aeb1e28cdde1a4c099e3dc4c31fc8ab0bd203ccdc095e9e6f284f368f9a82f16da298d8f95ad99b532c3
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-0.7.0.ebuild b/dev-python/build/build-0.7.0.ebuild
deleted file mode 100644
index 8555e5d4feb2..000000000000
--- a/dev-python/build/build-0.7.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
- >=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- tests/test_env.py::test_isolated_env_log
- tests/test_main.py::test_output_env_subprocess_error
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # Internet
- tests/test_main.py::test_build_package
- tests/test_main.py::test_build_package_via_sdist
- 'tests/test_util.py::test_wheel_metadata[True]'
- tests/test_util.py::test_with_get_requires
- )
-
- epytest -p no:flaky \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
diff --git a/dev-python/build/build-0.7.0-r1.ebuild b/dev-python/build/build-0.8.0.ebuild
index 049661a8726c..0aadcca52b3a 100644
--- a/dev-python/build/build-0.7.0-r1.ebuild
+++ b/dev-python/build/build-0.8.0.ebuild
@@ -19,12 +19,14 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/packaging-19.0[${PYTHON_USEDEP}]
>=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
"
BDEPEND="
test? (
@@ -52,12 +54,13 @@ python_test() {
# Internet
tests/test_main.py::test_build_package
tests/test_main.py::test_build_package_via_sdist
+ tests/test_self_packaging.py::test_build_sdist
+ tests/test_self_packaging.py::test_build_wheel
'tests/test_util.py::test_wheel_metadata[True]'
tests/test_util.py::test_with_get_requires
- )
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # fixed in git but the patch is large-ish
- tests/test_env.py::test_executable_missing_post_creation
+ # we don't really have to test that fallback
+ # (requires dev-python/toml that we'd like to lastrite eventually)
+ tests/test_projectbuilder.py::test_toml_instead_of_tomli
)
epytest -p no:flaky -n "$(makeopts_jobs)" \