summaryrefslogtreecommitdiff
path: root/dev-python/btrfs/btrfs-13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-14 15:21:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-14 15:21:15 +0100
commit1c382dc5dbc52576ac2300fee0498af8af44e7b4 (patch)
tree45d2492f5c659cbb01120d4192c9be34841362bd /dev-python/btrfs/btrfs-13.ebuild
parentb9e8f3cc44aed3b6da71c7510c6287bf7bbbc66b (diff)
Revert "gentoo auto-resync : 14:06:2023 - 15:13:45"
This reverts commit b9e8f3cc44aed3b6da71c7510c6287bf7bbbc66b.
Diffstat (limited to 'dev-python/btrfs/btrfs-13.ebuild')
-rw-r--r--dev-python/btrfs/btrfs-13.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/btrfs/btrfs-13.ebuild b/dev-python/btrfs/btrfs-13.ebuild
deleted file mode 100644
index 4d688620e0b6..000000000000
--- a/dev-python/btrfs/btrfs-13.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to inspect btrfs filesystems"
-HOMEPAGE="https://github.com/knorrie/python-btrfs"
-SRC_URI="https://github.com/knorrie/python-${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-S="${WORKDIR}/python-${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-001-docs-do-not-monkey-patch-for-sphinx-4.patch
- "${FILESDIR}"/${PV}-002-show_file_csum-fix-vaddr-computation.patch
- "${FILESDIR}"/${PV}-003-ioctl-fix-documentation-error-in-FeatureFlags.patch
- "${FILESDIR}"/${PV}-004-add-Block-Group-Tree.patch
- "${FILESDIR}"/${PV}-005-ctree-FileSystem-add-block_groups-function.patch
- "${FILESDIR}"/${PV}-006-btrfs-search-metadata-use-FileSystem-block_groups.patch
-)
-
-python_install_all() {
- if use examples; then
- # skip symlink meant for development
- rm examples/btrfs
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}