summaryrefslogtreecommitdiff
path: root/dev-python/bpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 09:55:31 +0100
commit9a8514e070a40648dbc8e28ad6457d925542b79a (patch)
tree5cc8ed0b0c8964ad196b7b3e502def202a997b32 /dev-python/bpython
parent2ecd7994be1409f2a65bfca700904d2a78fd7bbe (diff)
gentoo auto-resync : 26:10:2022 - 09:55:31
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.23-r1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 8b1547043bc0..5b6b4be21160 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,3 +1,4 @@
DIST bpython-0.23.tar.gz 222241 BLAKE2B eae70242323534dacada4d3d181ec4fba5fd384dc124bec7f28db887d2f1fb5b49ec6bc169d4a93db9de88dee82d714d502f2b2b1de5d9d01073f7504430cc23 SHA512 b25b68a690b838fef0c5dbb05565db4373ebb3611278b9f94db792ef25a43f59e3e9b7ac1ad0f571ae442948748b6c5e28888c6aa0f592cdf8499223cfded217
+EBUILD bpython-0.23-r1.ebuild 1161 BLAKE2B 28282068a0669f57e70ae8a57cb3533f2af877b978e64ec10b575905b9af1da63db710fbe6ad6d1034c816045ec0f94287fd99dc9e78db16ed96feb6e898a6ce SHA512 5631358cf26602a5f5f1b01cbfb700837c420b9753a9711a054ed44afb9d89d3727c87121617f828022f802218e854e1972146bf805d372013f4d4dde31f30cc
EBUILD bpython-0.23.ebuild 1212 BLAKE2B dc94f2f28a65b0f0bebdb58275ce816456e72634f45502538502d675fcdc05695bc0834c20e3982aad4d0d63de02a7ecfb8e024697aaff704b1923dbb0d803dd SHA512 7879958ab5dad7a499e00dc56a7dcb101d54a047cb59782dda4a8cbfde9c5af833c18f1f62ea03148332d1a78d4b7f990919f1118f64531daa4e418441933465
MISC metadata.xml 866 BLAKE2B 0abfdfadfdd88b477380ca383047987b12e2a4f6f8e666e1e8ac9a245da606fe587fec0ff406e0784396e41f8897dba84b02618b63fb8ffe56dbdb990b1bd2d4 SHA512 cc3b9f87ae93e16094cf7a227e5bd84db52f82dc7ed5e36d5d0f6b07a7242e314dcf8911e12ebf6d1e6574ff7d05833798b9a095d0696094b93941aaf68da45f
diff --git a/dev-python/bpython/bpython-0.23-r1.ebuild b/dev-python/bpython/bpython-0.23-r1.ebuild
new file mode 100644
index 000000000000..1bcd139c79b6
--- /dev/null
+++ b/dev-python/bpython/bpython-0.23-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="
+ https://www.bpython-interpreter.org/
+ https://github.com/bpython/bpython/
+ https://pypi.org/project/bpython/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="clipboard +jedi watch"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.4.0[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
+ jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
+ watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+"
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest