summaryrefslogtreecommitdiff
path: root/dev-python/bpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /dev-python/bpython
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/Manifest2
-rw-r--r--dev-python/bpython/bpython-0.17.1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 71bf220f8ffc..1f2a36bd5c9b 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,6 +1,8 @@
DIST bpython-0.16.tar.gz 201898 BLAKE2B 907f6a506d2b52db01e7b84c615574a7daad36f630646a345c963e432cc394330339390b6afc2585845b19d6c00d9c0b95e06b9d3b0fe85fe20daad3f5cf208a SHA512 1173d720aa679e4a6079c7febd36abbffa901604c99c6d1ce1e940a8fbcf8a4ba7bc526de0ef5290e3859a4384d1cd5cbef62fd9f056ddcb545b64d69d103a5b
+DIST bpython-0.17.1.tar.gz 213638 BLAKE2B 42530a38f8cf714a0415957a46374b83ad14dfab89a76317507763c2f83b3dbc8f71c7cc967ec353fabd38b6631130d34df99c0d53f3728fa2390d4a6f64b25d SHA512 5b5e861646df90510db75520dff9533b71501d35b7af1d152adf2c929b171fa6a2b1c0a6b7eda0311f9315703db161c6a78698a6cd434e5321464d6d1c033e4e
DIST bpython-0.17.tar.gz 214230 BLAKE2B dc26de037eb5698c04afb74472fe9483e1398f4f40b7da21520f2e7e2ba6e510bcbf200938d520d95b976a6fbeb31af7b1b1f828a022835edbe40d381c82797d SHA512 17c25f4ed69eb7cff27ba0a488434623a7105c60bbf1e6f608c91babf240741ab7a7097ad347f897cd5f39f2fedb944fd69d8dbfbc66da6b910e1a14ace6fd1f
EBUILD bpython-0.16-r1.ebuild 1487 BLAKE2B 0f53fba5e2f027ebda8071aaab20bee2ee93d40630d57d591f6b4a6479bb2475b57664e99a8a7c87849400a303260b9aeb7ebd7ec0342a3d847e2e0675b695d4 SHA512 21e61a4b6d34837c71b40b3248d48c37a547f966d28f429ae6742c173589808afc27b28441287e0c40312bab5a3a56fec25223de70ceb9d949f49c544bed0563
EBUILD bpython-0.16.ebuild 1483 BLAKE2B 25d5ab30d26946e42d2cf2345af7b37a9dc8d63267fe23d6fcdb977c3fce5d714eb7665f438c001b2bcfa877effda64d2f33179c20b7144570fe5ee83b8e4f13 SHA512 cd22c5d6ad08bc534255b5a58d9593fa75505b4b05064b520cb6653ff224a56e76e0e2bf37f55de4ea2254d2dbbf744a90b40f02c82978393feece634217bcab
+EBUILD bpython-0.17.1.ebuild 1487 BLAKE2B 8033a7c64ed187d0324d9f50452d1941c69a8b839b20b310412cbff7d9cec6c4a9e226d9f9023e85decdfcabb4f3788d242b8bd6836f1e33e3389616bcbdfd81 SHA512 e78faad5793a9f8b9aaa1be1ef27bc4ca94aa1d88dc727087edc59e3e7083c3a52948902b5c6c97784a0841fa115366c0d73e41fa729eca07c5ad5aebff18cb9
EBUILD bpython-0.17.ebuild 1487 BLAKE2B 8033a7c64ed187d0324d9f50452d1941c69a8b839b20b310412cbff7d9cec6c4a9e226d9f9023e85decdfcabb4f3788d242b8bd6836f1e33e3389616bcbdfd81 SHA512 e78faad5793a9f8b9aaa1be1ef27bc4ca94aa1d88dc727087edc59e3e7083c3a52948902b5c6c97784a0841fa115366c0d73e41fa729eca07c5ad5aebff18cb9
MISC metadata.xml 636 BLAKE2B 8a0306ee698c4f53a67ea4662791444115ba8e0cd14294614b7ff1dc6ddc28023897e3e3c4d4f0e8f8920c8fe6298ef8b866ead41df4871d2461f9c999e6c498 SHA512 84dc3ce1791ba626a1920d6ee3e5501ad6eb49528b7ba055811e1eda46a354d8e704a31b5c4ca7be5b4512f641098311ebb1c6651d889cedb6071a97a0aff9ba
diff --git a/dev-python/bpython/bpython-0.17.1.ebuild b/dev-python/bpython/bpython-0.17.1.ebuild
new file mode 100644
index 000000000000..6905eb544957
--- /dev/null
+++ b/dev-python/bpython/bpython-0.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.python.org/pypi/bpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/curtsies-0.2.11[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+# Req'd for clean build by each impl
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/sphinx/source/ \
+ doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
+ fi
+}
+
+python_test() {
+ pushd build/lib > /dev/null
+ "${PYTHON}" -m unittest discover || die
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
+ distutils-r1_python_install_all
+}