summaryrefslogtreecommitdiff
path: root/dev-python/bpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /dev-python/bpython
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/Manifest3
-rw-r--r--dev-python/bpython/bpython-0.21.ebuild9
-rw-r--r--dev-python/bpython/files/bpython-0.21-fix-py3.10.patch48
3 files changed, 55 insertions, 5 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 1f9e145a1ef3..d3a31f069b56 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,4 +1,5 @@
+AUX bpython-0.21-fix-py3.10.patch 1896 BLAKE2B e57af6c6a3e8769e4e82e919eade1414dd7c6823e2060fbc7fb60d1b7038765cc8eafeb2c19c04174fad7d668fe97a49b904efc2cc58ecbb5f8272145412c3d3 SHA512 49ecc91fa3c7e3e4b0d5b6fa7fcbf4ebce3fee3d8682f92960c2e469497239e770639c5ed30a57925dbb3a46d32ddde8bfdc477d69deebaba7e2cf4b75fc2f58
AUX bpython-sphinx-4.patch 393 BLAKE2B 09bddc348da1ac845554edc57ba37a6eb9eaa748c86647cc437557784ebb924b25ae80a7830ecb80ed73bfb6b06bf3fda2c124e9e1577b51b6322909e324ccdc SHA512 fb72027c11e52222adf25212299dc7ff3d2ee8710997d0f5f3882038448c57173a49e6619989bf0273b8bf8be676b8a7d1caa6860356d56d7421e30e2417fa4e
DIST bpython-0.21.tar.gz 208206 BLAKE2B 22db7abe3786df337af50f6217fa8c6702871b50de41245797270e70622084a22b3d6615cfe634044599a532c5bc14677b01dc77042d228213eaae2cad11b623 SHA512 a0eea1b9c2329ce5665456e99703ef476faab38f880eb8a330a6536970888cfdaada9f0e377d3c1acd8b6c79eb0c562ada43e82bac9df4cce5878594c3399ddf
-EBUILD bpython-0.21.ebuild 1127 BLAKE2B 4c5242c369be892f053269446169cc2a17a1a5fd9adb6fc1059bbc9c30c25448c59d4b380f37e62d3a7f09b4e5bd02091a845cb222c6fa6ccbdda7a120e69a43 SHA512 ac7234686089bc808e05694472c33e01f64adac9a951dab35bafe6f3b15db59101937e4bcbf82236ca40e2c04ea1605dd00e03aad84be5950878020ad6ca8d31
+EBUILD bpython-0.21.ebuild 1132 BLAKE2B 0368fe587ec53216f44d7a9dd5ca12aa0b019cf9545e77548e7f52d1737ba69d6686c05374fa604747674f873fbc29186dc6ed2111683aa4ffdb4a717d2572b1 SHA512 05bcd291576827a8cb522f510aba1d11e26bbb35a4c8997cdaff6bd82c12df1f7b3c4dd40f3fad3b334395ae31f23f9d0716f44421cabffc4d032919cf47293f
MISC metadata.xml 497 BLAKE2B 6f6d51971e2b77e2d2af5aab677b5133079b30045b30e54b3656e80afae25166deeaad6e6fd2eec097778b79af9fb97e38a534f769486d338305fda48caa3f82 SHA512 a5925763c19b0e34b5b988187c64bbcf1df80ea07d8f5515750e9031bf085aebe7f714dd07e799e624d95ce0e9eb4b74eab3045aa0508520b59df337e76e6698
diff --git a/dev-python/bpython/bpython-0.21.ebuild b/dev-python/bpython/bpython-0.21.ebuild
index b89b73167409..d815d9186569 100644
--- a/dev-python/bpython/bpython-0.21.ebuild
+++ b/dev-python/bpython/bpython-0.21.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
@@ -34,7 +32,10 @@ BDEPEND="
DOCS=( AUTHORS.rst CHANGELOG.rst )
-PATCHES=( "${FILESDIR}"/${PN}-sphinx-4.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-sphinx-4.patch
+ "${FILESDIR}"/${P}-fix-py3.10.patch
+)
distutils_enable_sphinx doc/sphinx/source --no-autodoc
distutils_enable_tests unittest
diff --git a/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch b/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch
new file mode 100644
index 000000000000..5b7c63767820
--- /dev/null
+++ b/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch
@@ -0,0 +1,48 @@
+From 78ead4c83d7c47c35ab075dd08114f51c24a709d Mon Sep 17 00:00:00 2001
+From: Thomas Ballinger <thomasballinger@gmail.com>
+Date: Wed, 6 Oct 2021 19:59:38 -0700
+Subject: [PATCH] Test Python 3.10 (#924)
+
+* Test Python 3.10
+* Update tests for Python 3.10
+
+--- a/bpython/test/test_curtsies_painting.py
++++ b/bpython/test/test_curtsies_painting.py
+@@ -139,6 +139,14 @@ def test_completion(self):
+ "└──────────────────────────────┘",
+ "Welcome to bpython! Press <F1> f",
+ ]
++ if sys.version_info[:2] < (3, 10)
++ else [
++ ">>> an",
++ "┌──────────────────────────────┐",
++ "│ and anext( any( │",
++ "└──────────────────────────────┘",
++ "Welcome to bpython! Press <F1> f",
++ ]
+ )
+ self.assert_paint_ignoring_formatting(screen, (0, 4))
+
+--- a/bpython/test/test_interpreter.py
++++ b/bpython/test/test_interpreter.py
+@@ -35,7 +35,19 @@ def test_syntaxerror(self):
+
+ i.runsource("1.1.1.1")
+
+- if sys.version_info[:2] >= (3, 8):
++ if sys.version_info[:2] >= (3, 10):
++ expected = (
++ " File "
++ + green('"<bpython-input-148>"')
++ + ", line "
++ + bold(magenta("1"))
++ + "\n 1.1.1.1\n ^^^^^\n"
++ + bold(red("SyntaxError"))
++ + ": "
++ + cyan("invalid syntax. Perhaps you forgot a comma?")
++ + "\n"
++ )
++ elif (3, 8) <= sys.version_info[:2] <= (3, 9):
+ expected = (
+ " File "
+ + green('"<input>"')