summaryrefslogtreecommitdiff
path: root/dev-python/bpython/bpython-0.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
commit7bd77a6744e2cd6d203240181996a998985e0288 (patch)
tree75dc88e47dcab0692b84f1b2684ffa9fde351aff /dev-python/bpython/bpython-0.23.ebuild
parentc33b50e5d2446c439465ff4575253db72ef2b8f6 (diff)
gentoo auto-resync : 26:11:2022 - 01:13:45
Diffstat (limited to 'dev-python/bpython/bpython-0.23.ebuild')
-rw-r--r--dev-python/bpython/bpython-0.23.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/bpython/bpython-0.23.ebuild b/dev-python/bpython/bpython-0.23.ebuild
deleted file mode 100644
index 89b0e7ea41d9..000000000000
--- a/dev-python/bpython/bpython-0.23.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
-HOMEPAGE="
- https://www.bpython-interpreter.org/
- https://github.com/bpython/bpython/
- https://pypi.org/project/bpython/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="clipboard +jedi urwid watch"
-KEYWORDS="amd64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/curtsies-0.4.0[${PYTHON_USEDEP}]
- dev-python/cwcwidth[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
- jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
- urwid? ( dev-python/urwid[${PYTHON_USEDEP}] )
- watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
-"
-# sphinx is used implicitly to build manpages
-BDEPEND="
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-
-DOCS=( AUTHORS.rst CHANGELOG.rst )
-
-distutils_enable_sphinx doc/sphinx/source --no-autodoc
-distutils_enable_tests unittest