summaryrefslogtreecommitdiff
path: root/dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild')
-rw-r--r--dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild b/dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..833b7c25e772
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-1.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast NumPy array functions written in Cython"
+HOMEPAGE="https://pypi.org/project/Bottleneck/"
+SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose )"
+
+python_test() {
+ ${EPYTHON} ./tools/test-installed-bottleneck.py
+}