summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-python/bottle
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest2
-rw-r--r--dev-python/bottle/bottle-0.12.16.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index da5008ed2891..b13d4205823e 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,6 +1,8 @@
AUX bottle-0.12.8-py3.5-backport.patch 1720 BLAKE2B 63081eee3765d060d7381a0eeca97fde17367273b0308449678301f0d2ed9357c90881aeeff31c6a26920ff256b76b0567a74628499fb4d9f2325bc75de6a2e8 SHA512 10f8b95d77d35db582be9bb937ca0c52050c22faa191f373b34039c6ddec24a8e71ce26f6bc9c3f3af7973670343b2f3131c02ed626e3d161a636f8c9e4cdd2b
DIST bottle-0.12.12.tar.gz 71554 BLAKE2B 4b0d0d77c5ebaddcafd44e16a052535ded566245324d39e97a39dd20a193360487f9489e8e89471dd92ca35d6c5b2e8cbe1572a958db31b69d32d3e32f1b6403 SHA512 cdba3859129680f08b8c641708fd884ccf46d404786cbf48435d752fece998a446f49799e4e05e979b967843866f3e966a35a6cac7aed3270df55fae508bae31
DIST bottle-0.12.13.tar.gz 70870 BLAKE2B d8bdef473181ce1cf6c0d1ea3537c407e68d23c1c44ca33e26c647d3b3783040d466b594c56c10cdd007d23bdf1708412d3e3ff108effa9e8a92e1b22f7a6c69 SHA512 86d106eb08e0b736a85aa69871f2d1e23c1d6f71948b85718daf131002c53c000e092ffdfe5b36c60460473467a2ca2b5af19767344689ffe638245e6859a80b
+DIST bottle-0.12.16.tar.gz 72248 BLAKE2B 21b5bc376648baec74577ac5b57fcacc58899babe07a034a436d5e2bde75a9e2e48b2569c5caf1478e77790c5fa327114ab9b084f014cc1ba97637d9ddfec659 SHA512 3c167f95902522c8f264e8478403da8e9b8cd84594318c4a773d38b7548b5ba95c99ef922033f6885cdc044b31f9c2e2f7ed263886637ce2a048e99c0c6e1403
EBUILD bottle-0.12.12.ebuild 1436 BLAKE2B 1f9e88d48d449c2754dbc0fd53910ed082e60ec8d73b0ed07e2c1562a9149cf331b72193e9a6803247181460c1ed4305b7af52278603df6c6e6cd414501bd38d SHA512 bfa08b0c9e6826f11e2a3d4818205d3ad1a193cb3838eb777e2e397c69ba4f3763da3b71233d091b347329ba95673d2d8ba2f7105cafa8c712cf1124a2ea951e
EBUILD bottle-0.12.13.ebuild 1459 BLAKE2B 55b14207cf3b0e0f1e59c9149308494ff22181cfb163811e60bafa185f96d7c854fc9bc3e682e3a1688ebfd41dd8935656f762ca2df247575a7e4c912ebb5db2 SHA512 f135aacec7b08d9daa733f8ba36993b4fbb7e84a57cda28bdc18d642f0b8019d2f1fd494875715a9e8ee25f32cd7da5448f159571a4170c415a0a81161df5ea1
+EBUILD bottle-0.12.16.ebuild 1456 BLAKE2B cc124e6b0993953b6a48722a18a673f90526f1f1494d0f7cf13d7cc501c47b0832a289486ff755856544b2f5d489b316bca1181809488bb191f38cd6bfc1d4b6 SHA512 3bac778ecdbf033524e968447c6cfe5059b719f5679519ab4856f44017b75b7b3c46d52f6f4165bb4da351683b87586d6a179e0fd1cd3dc453ca6bb0db0eb21b
MISC metadata.xml 319 BLAKE2B 29a2c856ee0a0af9214a5cec842b697fcb095d2bcf4702225b2e81d4f715967c29a383da78c43ac60d4464e27e651e81f1b085684b0b6f39925a6df7c36a54c4 SHA512 2ff50f032ea6042a32a7d391906ff95d00115367770423874aa6ee638b1db03fc0b7fabc484e1ecc002eff1e5abf5d45075463b76b7d512535d4820c46b56251
diff --git a/dev-python/bottle/bottle-0.12.16.ebuild b/dev-python/bottle/bottle-0.12.16.ebuild
new file mode 100644
index 000000000000..db42adc4ec38
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.org/project/bottle/ http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}