summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 20:03:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 20:03:41 +0100
commit799073eb168d35819904276f6c912be4ac76166a (patch)
treeb7e4e28f5c6de5e5a382f7578cc5d3249c1e6ea6 /dev-python/bottle
parenta11ba9ffa8140a9c55c950a6947bc472b489a10a (diff)
gentoo auto-resync : 03:08:2022 - 20:03:40
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest2
-rw-r--r--dev-python/bottle/bottle-0.12.23.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index f94a94e6f520..3a0f67693389 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,5 +1,7 @@
AUX bottle-0.12.19-py311.patch 1606 BLAKE2B 78808f90cf5c32ad6ac4675c3f55b144cb3d6d4fb5299a7e78de785553de13d5c9e44da78a9444aa92f869cede8d8e75a52773c1d5bea5d5a29893d27d8edbc4 SHA512 584ef8a5a66175841c318596c63c6ffa702a4c5b0958c1465f8def98a89aa32c9e36ad6caaf361bfdcfed050f4b2361e58b32fbffa2490014bd51c29244bd39d
AUX bottle-0.12.8-py3.5-backport.patch 1720 BLAKE2B 63081eee3765d060d7381a0eeca97fde17367273b0308449678301f0d2ed9357c90881aeeff31c6a26920ff256b76b0567a74628499fb4d9f2325bc75de6a2e8 SHA512 10f8b95d77d35db582be9bb937ca0c52050c22faa191f373b34039c6ddec24a8e71ce26f6bc9c3f3af7973670343b2f3131c02ed626e3d161a636f8c9e4cdd2b
DIST bottle-0.12.21.tar.gz 74229 BLAKE2B 88674389d2c087a7416443d031995ee923a98b790eb85d81b625f11b2fb0baee35d90a3ee2dba5b9d4744a343a34396a50edef0f85a2d6f4f0f4da95bae31b5b SHA512 3d621f6684f439a4a5718ad25e8b45eb0d1100cd565ec5b797adf67141e01d835cde671e687f5515cb6eab69bb465e9c7d004131634609266c2e1b69b0adbf43
+DIST bottle-0.12.23.tar.gz 73965 BLAKE2B ccd3dc3aad5c4c8b6899f55f03550cf9178e51788c27ece9808e1cff92693cc09dab145be16f814d29dae02ce53374a0470b2c4b032bc66a0ec2b1a11ec5ca44 SHA512 0550aa95680dd79d9c63c5de854845377183c86015893d9ee4e67126eca201582ef79d40ff0d1cbe79fe8a250118a775c63102475e337e18cfc1a65afe18f62a
EBUILD bottle-0.12.21.ebuild 1417 BLAKE2B f5c8c1d9e0f9a45aef84a0a68b7117d955b31d78988a104a5b668f60c37c8c4e5b9c312cd6d92b83c4af6bbe9518df5432af76726fba05ed14c4a0b2e2b27a3e SHA512 b11d4a990ff0986af51d0b90513c41169f62c7af08b2af30a7762c70aa8b54b442ebf45d8424ac2a888caf16a30d634666bb36b99a3082d52ceaf52eec8add85
+EBUILD bottle-0.12.23.ebuild 1227 BLAKE2B 4085c99058f1b3fe58f94d2e72a9f9f6f4a2e6635a31fbafad23ca30fdeaef48fb90ac43c5d0306f9ce7487ef209973324dae5a819c1924edf92d6426a14410c SHA512 c3b5db3395b3a90b5afb0d5bef5b025a96e44cff6541cd860f86a2e400d4e4606b5df9721c94b778b2de6807cd1b76c496a5185eef40f9b45d57192908c5094f
MISC metadata.xml 345 BLAKE2B aef224dc08d75b22612e8f781673a84f4de7a50d2dd2af98c31286cbfbae19a1f4777f60c279b73a5291e7167581640c1bf9928884c95d8489f6f6c2045b9898 SHA512 62bdb54efd9580ecba9372b45973138202d7524bad742fd8752ef09149daa5f650c278aabaadec3de7c852595775ca7c858451a3dbf78a8f1f4df11379fe275e
diff --git a/dev-python/bottle/bottle-0.12.23.ebuild b/dev-python/bottle/bottle-0.12.23.ebuild
new file mode 100644
index 000000000000..87a0756c7931
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.23.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -e '/scripts/d' -i setup.py || die
+
+ # Remove test file requiring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}