summaryrefslogtreecommitdiff
path: root/dev-python/bottle/bottle-0.12.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/bottle/bottle-0.12.16.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/bottle/bottle-0.12.16.ebuild')
-rw-r--r--dev-python/bottle/bottle-0.12.16.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/bottle/bottle-0.12.16.ebuild b/dev-python/bottle/bottle-0.12.16.ebuild
index 529b10e1111e..41250b4a6f30 100644
--- a/dev-python/bottle/bottle-0.12.16.ebuild
+++ b/dev-python/bottle/bottle-0.12.16.ebuild
@@ -1,24 +1,28 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
inherit distutils-r1 eutils
DESCRIPTION="A fast and simple micro-framework for small web-applications"
-HOMEPAGE="https://pypi.org/project/bottle/ http://bottlepy.org/"
+HOMEPAGE="https://pypi.org/project/bottle/ https://bottlepy.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_USEDEP}]
+ ' 'python*')
+ )"
RDEPEND=""
PATCHES=(
@@ -36,7 +40,7 @@ python_prepare_all() {
python_test() {
# A few odd fails in the suite under pypy
# https://github.com/bottlepy/bottle/issues/714
- "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
}
pkg_postinst() {