summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/botocore/botocore-9999.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 35239170e3a4..a1a5a4e1ea37 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -5,10 +5,14 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1 multiprocessing
DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="https://github.com/boto/botocore"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -22,7 +26,7 @@ fi
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
"
@@ -62,6 +66,5 @@ python_test() {
tests/functional/test_six_threading.py::test_six_thread_safety
)
- epytest tests/{functional,unit} \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
}