summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/botocore/botocore-9999.ebuild
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index cb37cb422ac5..638620b2cbc8 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -37,22 +37,14 @@ PATCHES=(
distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
+distutils_enable_tests pytest
src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die
- # very unstable
- sed -i -e 's:test_stress_test_token_bucket:_&:' \
- tests/functional/retries/test_bucket.py || die
distutils-r1_src_prepare
}
python_test() {
- # note: suites need to be run separately as one of the unit tests
- # seems to be leaking mocks and breaking a few functional tests
- nosetests -v tests/unit ||
- die "unit tests failed under ${EPYTHON}"
- nosetests -v tests/functional ||
- die "functional tests failed under ${EPYTHON}"
+ epytest tests/{functional,unit}
}