summaryrefslogtreecommitdiff
path: root/dev-python/boto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/boto
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/Manifest1
-rw-r--r--dev-python/boto/boto-2.49.0-r2.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
index 7cca41d5478f..c2200d2bd178 100644
--- a/dev-python/boto/Manifest
+++ b/dev-python/boto/Manifest
@@ -1,6 +1,5 @@
AUX boto-2.49.0-py38.patch 2061 BLAKE2B a17cc48925216f333a12631051f177c9d91199eddcb5dd08c22a3c8381af743b0aeeb7cd5642bb030e951596ee98477abf1e7507a4bfabc9d36706e7809bf031 SHA512 ba42dee03c39cf238c6cb1864500f5d6c0fabcc395021cba8745c3e4fc4e59828eb7f461d5251367d37c4e0709162117e97aeabc08f941fe07c65f6b179244d8
AUX boto-try-to-add-SNI-support-v2.patch 4329 BLAKE2B 3be0a3a88bc252bf8cbf316d3198b58ca86ee61e991400ce1e27854433bcf3709718593c58ffc2e2ad16fa41630a54670a4b7d42efde572073adf5f5f95994e2 SHA512 48b1fa089138a22ca9749fe82a1d92abf7570edf87a6ffc48f9b2389baed8982092afc2cbf1e35bf0661f185e96ba2b2b6d21cb2c553d6d884e800805f013a9a
DIST boto-2.49.0.tar.gz 1478498 BLAKE2B 6a897ea162f5f4bd34a2d488a3e3897f7f2f5b8707dd0922c01b6a0b90ea577223bf3e588b6685bda1f2bc0e92af426711fcba67a70377183465a530065c6c84 SHA512 2175cf30cd25bbc05812e83e5ade7668c3e21b1bb09aa1b43f0f0ac7d6967a646394fb52c9be673ebb65618c5b33a52d6f31f6da702f5cd1d6c9a18169476dd4
-EBUILD boto-2.49.0-r2.ebuild 979 BLAKE2B 08fb685e67b9ee564a1dc69591361a8ea49b9f2b5368f373aaa7a6f9f3ba936c4196d54880074f12fc51129c3839f22abf8d08626698169fc92d745e6e942b05 SHA512 85ca95a2a703e2a49302917cfb6e39b5c65301495d9191c2b64066f29e17bfc324a6c7ee70ec147917f90740153fa356b9aa86eca9e8132839a34a5812709c96
EBUILD boto-2.49.0-r3.ebuild 1310 BLAKE2B bd06cb61e052ba15060dc57c3081a2c9182e93c87c14d605fbff0d8788e417ff7ac6e1b5e16f1eaa2cbae8efc1be0e849e54f6b195a451a001e85e95167366ec SHA512 13dfbd1d01e47416ea93b6d3e0fd2d5f06bcf97801dd50634d76021e43bc94044047842c0316010eaa7d01d63c6c5577db0f47da36c0937d500b903d8415e954
MISC metadata.xml 419 BLAKE2B c6c19e4ba3ecc5a36b535267b75cdf3afb7317e577e8f0899d43a334632633d771b5e5216517537616cc99c7766a852d2b4c5b132e174f8481d86649253e0897 SHA512 ee5587224538b14f67c30eda60c161e4c07c801c4b4edb24bcb0350e17c4d655c4d9a6907ebe5913d7689e1b6078ef25f47b4fe0a7c655cfa8d5ea775b4d0329
diff --git a/dev-python/boto/boto-2.49.0-r2.ebuild b/dev-python/boto/boto-2.49.0-r2.ebuild
deleted file mode 100644
index 979cf15da746..000000000000
--- a/dev-python/boto/boto-2.49.0-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
-
-DESCRIPTION="Amazon Web Services API"
-HOMEPAGE="https://github.com/boto/boto https://pypi.org/project/boto/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-PATCHES=(
- # taken from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909545
- "${FILESDIR}/boto-try-to-add-SNI-support-v2.patch"
- "${FILESDIR}"/${P}-py38.patch
-)
-
-distutils_enable_tests nose
-
-src_prepare() {
- # broken, not worth fixing
- rm tests/unit/cloudfront/test_signed_urls.py || die
- # fix tests
- mkdir -p "${HOME}"/.ssh || die
- : > "${HOME}"/.ssh/known_hosts || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- nosetests -v tests/unit ||
- die "Tests fail with ${EPYTHON}"
-}