summaryrefslogtreecommitdiff
path: root/dev-python/boto3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-python/boto3
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.10.2.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2c84a88fe52d..c03066d1cd2b 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,5 +1,7 @@
+DIST boto3-1.10.2.tar.gz 272071 BLAKE2B 9c3b90ae751784946a84d0cf31ed0111526ed97b5be1fe5f256f725889f9819db632c6e6f217e3f01ebb0aa5594257a5bdaabd8dcc5f14ccb5bdd333b1c416c7 SHA512 37ea11f5ae9263aa5e97ce94f2834c987190ba2eac4a60bf9312bb643f1d204e48db7bef6ddc0d46ae124109ec6807589108b58f3024485de163fd8f83688b42
DIST boto3-1.9.122.tar.gz 258061 BLAKE2B 68903edd97e10693675e4c2fa77c2c54f2d3aab79307ee0a856f43aabe256f7782d027b0a23f433c593962c90f7364c26a87c27fe8770e67b5052e4ced73a9bc SHA512 31b8d8c2369b9076d825196d400c8a8b5579c38f87c7f41634eedbdaf6c2be01072018312e90e25d81b850c51f7c22a13fa565cd4e8b7672c238bad61e6a0810
DIST boto3-1.9.4.tar.gz 237313 BLAKE2B 20ab73dd02864b455a2bcc567b6303ef8b0503c4dd80efb442bf7ad8167329c938dcd41cbc61d4ab50fd02cbf8758c10aadb9b13d9c795330fe1faf9a1f7352b SHA512 7f0eb3b5537aed598d75a05474439819dee8c0030dd1eb685281e963ec465699ff9120394170f1ac7b53493de9b8702ec789863839eb3710ff3d60e2dfc1f1ac
+EBUILD boto3-1.10.2.ebuild 1225 BLAKE2B 2d8dc5ba2b83ab3def6d37821147ed6e6c42676cac7def1cdf5ddfe0396c178a42662282157bce19421c8a57f51ef074514d306d0fb77bfd61a8c419a51bcc98 SHA512 cbc7886265dfb947f020b72498118dc3af9c00b75e3d2744316c02d7fe09c380b87568a34dfb38521be5e1f444f1fe251bcdf14cdbb2138f92562090ec58abfc
EBUILD boto3-1.9.122.ebuild 1223 BLAKE2B 524f6253ae78c1a0732c364ff5cb83ed3477ee896c12ce1c66a76ccd9fa2e555a8b77c0bc77bafe96f77c5f90cf8e1a577ed39c4ccb97defadf8c45cb7d0713f SHA512 f4e8bd983fc057112f035e7b9768604f23859d301bab10cc138ab98207270bf1da8c4f96464128d2deeb75d501d89d150731b504aa2ff39ac9ad5ea3076d537e
EBUILD boto3-1.9.4-r1.ebuild 1223 BLAKE2B 524f6253ae78c1a0732c364ff5cb83ed3477ee896c12ce1c66a76ccd9fa2e555a8b77c0bc77bafe96f77c5f90cf8e1a577ed39c4ccb97defadf8c45cb7d0713f SHA512 f4e8bd983fc057112f035e7b9768604f23859d301bab10cc138ab98207270bf1da8c4f96464128d2deeb75d501d89d150731b504aa2ff39ac9ad5ea3076d537e
EBUILD boto3-9999.ebuild 1225 BLAKE2B 2d8dc5ba2b83ab3def6d37821147ed6e6c42676cac7def1cdf5ddfe0396c178a42662282157bce19421c8a57f51ef074514d306d0fb77bfd61a8c419a51bcc98 SHA512 cbc7886265dfb947f020b72498118dc3af9c00b75e3d2744316c02d7fe09c380b87568a34dfb38521be5e1f444f1fe251bcdf14cdbb2138f92562090ec58abfc
diff --git a/dev-python/boto3/boto3-1.10.2.ebuild b/dev-python/boto3/boto3-1.10.2.ebuild
new file mode 100644
index 000000000000..bb665fd73e2b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.10.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-1.12.4[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/s3transfer[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/guzzle_sphinx_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}