summaryrefslogtreecommitdiff
path: root/dev-python/boto3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /dev-python/boto3
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.26.100.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 98d7cb620d20..ceb073e720e1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,6 +1,8 @@
+DIST boto3-1.26.100.gh.tar.gz 627269 BLAKE2B 1481e456b73794a4f371e5ac935d3d777c5315c1da39f8565631f62e05bd218e85409d5e5e095057af2c05c4bbcd9c1c5a56b4d1b8d2ef8e97ec567bfdd959a3 SHA512 45fdbb31c7e39ac1775e89755f88d426bdd17be002a13c1c517f2ec4b7ce1fcf0df7d1ff6c6d678fab5a7a1d656f9f609a6d4b3ab779464ea14a3e52eb7e4771
DIST boto3-1.26.89.gh.tar.gz 615718 BLAKE2B 3257e6efafaf139daf935385c252c10929be2a4277a8f0f192afc6dbd7cc32fa8f940a4e59ebbe25931c399dedb926a3c1848bd9cc0a7f0d377acb302eabe3b0 SHA512 02ee02b05023e9184f779ab8ff21afa6f7e56f7d2e883d021b2567676c5fc57cad6b475d55316a2017c2a837c41d2f5604824f440060e2f96804c5a61ccdd143
DIST boto3-1.26.94.gh.tar.gz 617861 BLAKE2B 908b40868735038810cf75c903bbc8bad00a6ea8776b2a5a236683f18f2185971f8a13db5349086b1aef2c4d51361c8ebf30f2d671cea7f4101c9882a59b6acf SHA512 036278668afa33dfdaab9cc2e02c2c3e0596ec1c1b407767f22bc6a4cd87913f883f85430ff6a120c5e0fdd2194b70c911fe7a207bc26ed5fcd415f3754cde35
DIST boto3-1.26.99.gh.tar.gz 625932 BLAKE2B 961a640995abdafbf2cd73f83ed5af0e1314cebbc5dc154771204e7c16532ad4a84aed08cbd7789af30de518bf2e8bd5204e9a540a2d3a08e75222c2eeb9a68a SHA512 ff726483a83a11a8c088905998af0a1a791e87503b39422811d82b3122275a24eb955636407422af7552908eee22d4c1369779a7798f09f958a8af5234c0c11d
+EBUILD boto3-1.26.100.ebuild 1587 BLAKE2B db535a9938316c0564a32f4e05e74349251daef0db47afee54fe6907409d11ba1d660027cf059e2d4889c580ab8fe2fd6b252dd25a9c1906c878df6cb52e49d2 SHA512 8f2d0fdfbe2fa3916821a5d884cf579d55f97c21853c2f0990402e9ebbe4f1b0d21fda262f6e0ed997890b0cfe1e7ac42b1b6832a683c6b27f4aa2b6d4697469
EBUILD boto3-1.26.89.ebuild 1580 BLAKE2B 6c2b0aa540898e7461c165b8cb755ceec1cf0b94ba8cf4e2183bcd3a7a242b1e78f4c9a61bcb0c01230f625735a59ce3cd437098b19620d87c76fa022327af45 SHA512 f792df64912dbb7af89eac9c95518624a26c37387e16b96f46db928912c01ce20503cf8f9685de1b314ca7120e353c5fb26c900962f8c05e2c275b3bcd297555
EBUILD boto3-1.26.94.ebuild 1587 BLAKE2B db535a9938316c0564a32f4e05e74349251daef0db47afee54fe6907409d11ba1d660027cf059e2d4889c580ab8fe2fd6b252dd25a9c1906c878df6cb52e49d2 SHA512 8f2d0fdfbe2fa3916821a5d884cf579d55f97c21853c2f0990402e9ebbe4f1b0d21fda262f6e0ed997890b0cfe1e7ac42b1b6832a683c6b27f4aa2b6d4697469
EBUILD boto3-1.26.99.ebuild 1587 BLAKE2B db535a9938316c0564a32f4e05e74349251daef0db47afee54fe6907409d11ba1d660027cf059e2d4889c580ab8fe2fd6b252dd25a9c1906c878df6cb52e49d2 SHA512 8f2d0fdfbe2fa3916821a5d884cf579d55f97c21853c2f0990402e9ebbe4f1b0d21fda262f6e0ed997890b0cfe1e7ac42b1b6832a683c6b27f4aa2b6d4697469
diff --git a/dev-python/boto3/boto3-1.26.100.ebuild b/dev-python/boto3/boto3-1.26.100.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.100.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}