summaryrefslogtreecommitdiff
path: root/dev-python/boto3/boto3-1.34.91.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-27 23:59:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-27 23:59:43 +0100
commit413421048cc2b0df9a218f0ab3cb151846809eb5 (patch)
tree3fd887035aa0f5b65d7f147ab77caa98c44c148d /dev-python/boto3/boto3-1.34.91.ebuild
parent3e42d1577189af123b773dc0f11e5419035308c8 (diff)
gentoo auto-resync : 27:04:2024 - 23:59:42
Diffstat (limited to 'dev-python/boto3/boto3-1.34.91.ebuild')
-rw-r--r--dev-python/boto3/boto3-1.34.91.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/boto3/boto3-1.34.91.ebuild b/dev-python/boto3/boto3-1.34.91.ebuild
deleted file mode 100644
index 2c733040b7a3..000000000000
--- a/dev-python/boto3/boto3-1.34.91.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="
- https://github.com/boto/boto3/
- https://pypi.org/project/boto3/
-"
-SRC_URI="
- https://github.com/boto/boto3/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest tests/{functional,unit}
-}