summaryrefslogtreecommitdiff
path: root/dev-python/bokeh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/bokeh
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/Manifest3
-rw-r--r--dev-python/bokeh/bokeh-0.12.6.ebuild76
-rw-r--r--dev-python/bokeh/metadata.xml23
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
deleted file mode 100644
index b7d94f6de152..000000000000
--- a/dev-python/bokeh/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST bokeh-0.12.6.tar.gz 13720124 BLAKE2B e8fc1c42b530622bf6de8e13e81ae45e6d47985cef1ed81a2e32bfaef2a246a09c25210728cf434da6d4a0ef8f47ade1be5ee9e9318cc0a071bff36b317069a1 SHA512 7a293169521b690bb2cdcefe3667f869e75f2b718d6122af63201e2fb2e530eba931b3fa2ee3474a8ead758039cbb7d756acc0349e2f0820d72a4f754b9301b2
-EBUILD bokeh-0.12.6.ebuild 2102 BLAKE2B 524d403a63ad307c7255b78caa0ca109ba99d1d51fb6c1e97480fb4e1b51821477004e11506c0e222964062ef6bff8165859e9eaa5649acae750c9f241ebf416 SHA512 96ec0e73a6084832b6635e971c2e74e86d25fbb972a25367dc54ac3ce576a872a3b45b7cbb79cf6ccd3264d2344f29c123f5800565a4ec985cf0fe8bda8f9544
-MISC metadata.xml 879 BLAKE2B edcba4dfedb81192edd9a32b2ad320582129f0efdd9ccab46d99ebc0e561784f04f53fe1dd80243513ea0a69ab3dfeb1d36cda6a5b37585cc26e2c203194a8bc SHA512 46419cc11f266c9e5d51b35c4bd4a75c4c82446dc8a9f06b6ac7ef3c742a371334b56e98a4bc831bc4f5ccee0222ba7f2b36a44d32fc4ea3aaa092b32c7429c9
diff --git a/dev-python/bokeh/bokeh-0.12.6.ebuild b/dev-python/bokeh/bokeh-0.12.6.ebuild
deleted file mode 100644
index 443dae5fd0f7..000000000000
--- a/dev-python/bokeh/bokeh-0.12.6.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Statistical and interactive HTML plots for Python"
-HOMEPAGE="https://bokeh.pydata.org/en/latest/
- https://github.com/bokeh/bokeh
- https://pypi.org/project/bokeh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=net-libs/nodejs-4.1
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
- test? (
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/flexx[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/selenium[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )
-"
-
-python_compile() {
- esetup.py build --build-js
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- py.test -m 'not (js or examples or integration)' -vv || die
-}
-
-python_install_all() {
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples/"
- doins examples/*
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/bokeh/metadata.xml b/dev-python/bokeh/metadata.xml
deleted file mode 100644
index da849fdc2a30..000000000000
--- a/dev-python/bokeh/metadata.xml
+++ /dev/null
@@ -1,23 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- Bokeh is a Python interactive visualization library for large
- datasets that natively uses the latest web technologies. Its goal is
- to provide elegant, concise construction of novel graphics in the
- style of Protovis/D3, while delivering high-performance
- interactivity over large data to thin clients.
-</longdescription>
- <upstream>
- <remote-id type="pypi">bokeh</remote-id>
- <remote-id type="github">ContinuumIO/bokeh</remote-id>
- <maintainer status="unknown">
- <email>info@continuum.io</email>
- <name>Continuum Analytics</name>
- </maintainer>
- </upstream>
-</pkgmetadata>