summaryrefslogtreecommitdiff
path: root/dev-python/blurb/blurb-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/blurb/blurb-1.1.0.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/blurb/blurb-1.1.0.ebuild')
-rw-r--r--dev-python/blurb/blurb-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/blurb/blurb-1.1.0.ebuild b/dev-python/blurb/blurb-1.1.0.ebuild
new file mode 100644
index 000000000000..902953b276f7
--- /dev/null
+++ b/dev-python/blurb/blurb-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="https://github.com/python/core-workflow/tree/master/blurb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_test() {
+ # Tests expect to be run from github repo, in which code is inside dir
+ ln -s . blurb || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" -m blurb test || die "Tests failed with ${EPYTHON}"
+}