summaryrefslogtreecommitdiff
path: root/dev-python/bluelet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/bluelet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/bluelet')
-rw-r--r--dev-python/bluelet/Manifest3
-rw-r--r--dev-python/bluelet/bluelet-0.2.0.ebuild27
-rw-r--r--dev-python/bluelet/metadata.xml13
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bluelet/Manifest b/dev-python/bluelet/Manifest
new file mode 100644
index 000000000000..606993113c22
--- /dev/null
+++ b/dev-python/bluelet/Manifest
@@ -0,0 +1,3 @@
+DIST bluelet-0.2.0.tar.gz 14182 BLAKE2B c05560f4cd1b4aaf3f25d22bbf5eabfef695cb1686742ae274df9024786ca08a4604ec9a24ad185718ad8d8876f8b5fb12df0f45cdda5b61fb6fbdc8fb09bcaf SHA512 58bd8df4b61f23a53f9310b68e5754155c00d598c9bcb7724e90ef6722ee5d6017751c2e056eaaa64cca71b89c391d248c14477457f30ebf2b28841a3fdc98fa
+EBUILD bluelet-0.2.0.ebuild 581 BLAKE2B a7dd5815390bcae8f8e50fd2e1e74e8413971b407544e6ef814822358745e3742ea37aa9b1fd6ad9de9cf85ea691a3a95ccd19ad153dbe0ed32471ab89d7e213 SHA512 a29995ff3e62b47c4dd404b32d407ce6f55dc06c3e1bef0ace1ea348634ffe5efa1e2af2caf4f52277efcf41513ab4c62052d070cb560fe8089ce0b3ada57b9c
+MISC metadata.xml 969 BLAKE2B 64de2c903db588aa64c305a35d712d4a8905051cf021968081f39ade06cb393ef2028f96401259b359497d0acb422827f640333485bd7f5ace79a6fca7ab782e SHA512 98ec10adf32ffc4b2adcaa10f08e3e8f24e06aa22b66cb9a372952583153688349b11bb99654b8c53901b073085dcfbba6fe11b943b6ada86116d36163b89908
diff --git a/dev-python/bluelet/bluelet-0.2.0.ebuild b/dev-python/bluelet/bluelet-0.2.0.ebuild
new file mode 100644
index 000000000000..5f50a472e81d
--- /dev/null
+++ b/dev-python/bluelet/bluelet-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for pure Python asynchronous I/O using coroutines"
+HOMEPAGE="https://pypi.org/project/bluelet/"
+SRC_URI="https://github.com/sampsyo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ if use examples; then
+ docompress -x usr/share/doc/${P}/demo
+ dodoc -r demo/
+ fi
+}
diff --git a/dev-python/bluelet/metadata.xml b/dev-python/bluelet/metadata.xml
new file mode 100644
index 000000000000..770a684c6260
--- /dev/null
+++ b/dev-python/bluelet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+Bluelet is a simple, pure-Python solution for writing intelligible asynchronous socket applications. It uses PEP 342 coroutines to make concurrent I/O look and act like sequential programming.
+
+In this way, it is similar to the Greenlet green-threads library and its associated packages Eventlet and Gevent. Bluelet has a simpler, 100% Python implementation that comes at the cost of flexibility and performance when compared to Greenlet-based solutions. However, it should be sufficient for many applications that don't need serious scalability; it can be thought of as a less-horrible alternative to asyncore or an asynchronous replacement for SocketServer (and more).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sampsyo/bluelet</remote-id>
+ </upstream>
+</pkgmetadata>