summaryrefslogtreecommitdiff
path: root/dev-python/blosc/blosc-1.10.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 09:01:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 09:01:31 +0000
commite9bf3526a3a5e02396f24203bf8535a21b6f9784 (patch)
treea14d6832a5139117f06ad9045537f23d4b6fbf58 /dev-python/blosc/blosc-1.10.6.ebuild
parent4b70b249bd1fe7302633ca0b4f7abd22dd269d02 (diff)
gentoo auto-resync : 31:01:2023 - 09:01:31
Diffstat (limited to 'dev-python/blosc/blosc-1.10.6.ebuild')
-rw-r--r--dev-python/blosc/blosc-1.10.6.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/blosc/blosc-1.10.6.ebuild b/dev-python/blosc/blosc-1.10.6.ebuild
deleted file mode 100644
index 4d70e9f0f988..000000000000
--- a/dev-python/blosc/blosc-1.10.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=python-blosc-${PV}
-DESCRIPTION="High performance compressor optimized for binary data"
-HOMEPAGE="
- https://www.blosc.org/
- https://github.com/Blosc/python-blosc/
- https://pypi.org/project/blosc/
-"
-SRC_URI="
- https://github.com/Blosc/python-blosc/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/c-blosc-1.19.0:=
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/scikit-build[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( ANNOUNCE.rst README.rst RELEASE_NOTES.rst )
-
-src_configure() {
- export USE_SYSTEM_BLOSC=1
- export BLOSC_DIR="${EPREFIX}/usr"
-}
-
-python_test() {
- "${EPYTHON}" -m blosc.test -v || die
-}