summaryrefslogtreecommitdiff
path: root/dev-python/blinker/blinker-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
commit5181ced3f3566a9610b85922b083c8f84f20d78f (patch)
treed7eb288527e8bc248dd17ff874995d8bffe06704 /dev-python/blinker/blinker-1.8.2.ebuild
parent7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (diff)
gentoo auto-resync : 08:05:2024 - 00:00:57
Diffstat (limited to 'dev-python/blinker/blinker-1.8.2.ebuild')
-rw-r--r--dev-python/blinker/blinker-1.8.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/blinker/blinker-1.8.2.ebuild b/dev-python/blinker/blinker-1.8.2.ebuild
new file mode 100644
index 000000000000..9df417e40e36
--- /dev/null
+++ b/dev-python/blinker/blinker-1.8.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="
+ https://github.com/pallets-eco/blinker/
+ https://pypi.org/project/blinker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}