summaryrefslogtreecommitdiff
path: root/dev-python/blessings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/blessings
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/blessings')
-rw-r--r--dev-python/blessings/Manifest5
-rw-r--r--dev-python/blessings/blessings-1.6-r1.ebuild29
-rw-r--r--dev-python/blessings/blessings-1.6.1.ebuild29
-rw-r--r--dev-python/blessings/metadata.xml13
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/blessings/Manifest b/dev-python/blessings/Manifest
new file mode 100644
index 000000000000..84efb793ad5c
--- /dev/null
+++ b/dev-python/blessings/Manifest
@@ -0,0 +1,5 @@
+DIST blessings-1.6.1.tar.gz 20122 BLAKE2B b2158f3fd538ef8641438bce7800efc9417e9febec6509d0e11389277b02ee03e661fe70198176a6a3578c216aeb4a6957da28d090cb1dc2849efff135cdf400 SHA512 7a4b051e448cddde7e8ce24106ce0d5d893eb442b19fff04f9ddf28381dfa1b4bdd4be79b87782162b2ead13597a346f533edb944130f2e5bc39aa936ca48db2
+DIST blessings-1.6.tar.gz 19974 BLAKE2B 5b454c7199c637f9b8d4de69a92b8137e65b925898064f31dabb56bf4fd7af8b3374b7311bcd0369b668868bc2335ce945306c242c1bf58d6d7d50c09150c017 SHA512 5d0fc365416bf2b36b6de72f6b8c01bf0ab8df4a0148f492c80056a9ebd5d569e9c01966481e0d70a25add16da2bc3e73be933226369abca533ce019f97479f2
+EBUILD blessings-1.6-r1.ebuild 800 BLAKE2B a3eb3d7a1d9ca0f743485463351027fcf0812a66b2b32a5f5401a01c5cdc1e7d820a351aec84d5ec99edd4237be46621af55e24608d8ac771263baa35ae8d5d7 SHA512 5cf8663d878760edbdeaee1125aa3a79f7b8e5fd2633ada530523abbe6eb10bcdb2a8c2f15934425bcff5fda2c4fd31f613110bf93ed2f1502243b491d99b42e
+EBUILD blessings-1.6.1.ebuild 802 BLAKE2B f92d00a6a694b9c9826ceba99da08f3fe0f335518dbf10097824b123e2158f8c65e3612ace408c4a80f2be298266bf41424f85ffa229ddcc8ea65a6a106ddd8f SHA512 6b0931b408cd5c9543a0b0f1d9eb637fbf7c98561d16e8609b2d21f5d810fc3f248d4e3482ee9a3645385532802fbbb977ce768d4147a3d50a7fe6055d5da9db
+MISC metadata.xml 450 BLAKE2B d5969d6f857cb2ef4927505a351baaa6116bc3b85c1e54a1afd031cc903909ababfa7fd76c01fc9ee4a4bb6ff33552ab984f902932bd8772f11ec931f8fa99dc SHA512 8851fc3ed67dbdbe0efb8fd1712101644793086e6d84fe52fd54d741d81f4c30bb666e1aa82bfc111e2f264e3a238c6059d8be6844a05819b285cc913ade0231
diff --git a/dev-python/blessings/blessings-1.6-r1.ebuild b/dev-python/blessings/blessings-1.6-r1.ebuild
new file mode 100644
index 000000000000..c9fc69135b11
--- /dev/null
+++ b/dev-python/blessings/blessings-1.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A thin, practical wrapper around terminal coloring, styling, and positioning"
+HOMEPAGE="https://github.com/erikrose/blessings https://pypi.org/project/blessings/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/blessings/blessings-1.6.1.ebuild b/dev-python/blessings/blessings-1.6.1.ebuild
new file mode 100644
index 000000000000..274a823d6ab1
--- /dev/null
+++ b/dev-python/blessings/blessings-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A thin, practical wrapper around terminal coloring, styling, and positioning"
+HOMEPAGE="https://github.com/erikrose/blessings https://pypi.org/project/blessings/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/blessings/metadata.xml b/dev-python/blessings/metadata.xml
new file mode 100644
index 000000000000..b873a1b476ed
--- /dev/null
+++ b/dev-python/blessings/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">blessings</remote-id>
+ <remote-id type="github">erikrose/blessings</remote-id>
+ <bugs-to>https://github.com/erikrose/blessings/issues</bugs-to>
+ </upstream>
+</pkgmetadata>