summaryrefslogtreecommitdiff
path: root/dev-python/blessed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-04 09:13:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-04 09:13:04 +0000
commit20169f1085969ebed8224ad70b3c5901602aed28 (patch)
treef7fdb1805284875cb58bf632aa0368b6b0febf9e /dev-python/blessed
parent9f132437f051249512ed158be2229f6138332307 (diff)
gentoo auto-resync : 04:02:2023 - 09:13:04
Diffstat (limited to 'dev-python/blessed')
-rw-r--r--dev-python/blessed/Manifest2
-rw-r--r--dev-python/blessed/blessed-1.20.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/blessed/Manifest b/dev-python/blessed/Manifest
index 6aad1ca3e5ba..11887e7ac337 100644
--- a/dev-python/blessed/Manifest
+++ b/dev-python/blessed/Manifest
@@ -1,3 +1,5 @@
DIST blessed-1.19.1.tar.gz 6653802 BLAKE2B 5755efde3c203ab21a8994e29c55cdaace1cca772c9cdee4343562bb8ee4f9ffdee97d9131646d8385ef7e46664d23723ba46a3807d85623d9512ca40c7c4002 SHA512 0d899c42d7c6246362081bdc5d7dd2fcb13209fe0cee7e5a4fa342bdaf16a5cc21ab7e402bc5287ab1239f7e3afb02381e0e57e2d6111b80fe3c52b92cfa0f84
+DIST blessed-1.20.0.tar.gz 6655612 BLAKE2B 10523940ac2fe528487f2d1d68d9f38782ec260f1f42735940219d37d4b4dbaef2fd4ca63d753780123d54ae39ab04652d2c6ba8f3323c621a2206b0a706f6e0 SHA512 8567ff1c55f68ad99c6c524edbf8ee57813d23d885dcb372767debc76bc2d75642c2b0491e1ed05460f023c28403b5dabb13769dea101a1c6e3156c82e0d0355
EBUILD blessed-1.19.1.ebuild 1306 BLAKE2B afa6520d17474b9b2cb582879764c6ec2fa33e747d48d5a645c00a0b855ebebc10e4f06611cf7b67aac06aae151f84ced234bb4e75e33c6e0fbaa3c22fb38a2c SHA512 08fac719a626e9bbf3ea306f9983946e18ffd9cc0a13586523244ff54ae7248837efd1837028a52519ab2fba2287e643aef87163089d9c71ab4215bff2f1ab1c
+EBUILD blessed-1.20.0.ebuild 1348 BLAKE2B c3724c4e808a8fd60d41dbc2054de29fcabace4dfe599a11669b0ac1a68b3b37831d2b120555957e74cf46db5e33e708eed00e589fdbba30ef1968873367f056 SHA512 c89b8ad0cc1d9094c468f24569b502d66dd049f6aeef672d5e068bd0cca2f580858ce87665599c8663a10922c40383684ae3eabc49bb41f3482ee146d26d85a0
MISC metadata.xml 557 BLAKE2B dbfca7b52ee79a095475d591fb6fd4c151309e5e9c0c9e1e4dd031b66dc3128f9e0057eab3fa85d9fc875ba14b1229e81b8101626e341dccf597f0a6db97c42f SHA512 b0c74de041336d52276075ffc75f58827812a672016c30411888cd9ffc1e468120ef9a847ae16cf7eddd892e7176aafc4d9b635c1826d8ab98d7259d642cb6e3
diff --git a/dev-python/blessed/blessed-1.20.0.ebuild b/dev-python/blessed/blessed-1.20.0.ebuild
new file mode 100644
index 000000000000..243e96498758
--- /dev/null
+++ b/dev-python/blessed/blessed-1.20.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for making terminal apps using colors, keyboard input and positioning"
+HOMEPAGE="
+ https://github.com/jquast/blessed/
+ https://pypi.org/project/blessed/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip those extensions as they don't have a Gentoo package
+ # Remove calls to scripts that generate rst files because they
+ # are not present in the tarball
+ sed -e '/sphinxcontrib.manpage/d' -e '/sphinx_paramlinks/d' \
+ -e '/^for script in/,/runpy.run_path/d' \
+ -i docs/conf.py || die
+ # Requires pytest-xdist and has no value for us
+ sed -i '/^looponfailroots =/d' tox.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # COLORTERM must not be truecolor
+ # See https://github.com/jquast/blessed/issues/162
+ # Ignore coverage options
+ COLORTERM= epytest --override-ini="addopts="
+}