summaryrefslogtreecommitdiff
path: root/dev-python/black/black-23.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-23 07:52:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-23 07:52:18 +0000
commit4035d30ea0ada73d992bb7d583c0b37a053714fe (patch)
tree7a69165d1193f74105c13af2ed89082f75db7fe1 /dev-python/black/black-23.12.1.ebuild
parent686be77442c7f389d8c06c6dafb97294b819146b (diff)
gentoo auto-resync : 23:12:2023 - 07:52:17
Diffstat (limited to 'dev-python/black/black-23.12.1.ebuild')
-rw-r--r--dev-python/black/black-23.12.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/black/black-23.12.1.ebuild b/dev-python/black/black-23.12.1.ebuild
new file mode 100644
index 000000000000..05c24fb84ca9
--- /dev/null
+++ b/dev-python/black/black-23.12.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.7.4[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # incompatible with xdist
+ tests/test_black.py::TestCaching::test_output_locking_when_writeback_diff
+ tests/test_black.py::TestCaching::test_failed_formatting_does_not_get_cached
+)
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}