summaryrefslogtreecommitdiff
path: root/dev-python/binaryornot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/binaryornot
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/binaryornot')
-rw-r--r--dev-python/binaryornot/Manifest2
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild31
-rw-r--r--dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch13
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/binaryornot/Manifest b/dev-python/binaryornot/Manifest
index 68c4df2f9552..58adf47bf628 100644
--- a/dev-python/binaryornot/Manifest
+++ b/dev-python/binaryornot/Manifest
@@ -1,4 +1,6 @@
+AUX binaryornot-0.4.4-fix-version-number.patch 391 BLAKE2B cde44c468996c18513115daee310eabbd267c2192a947ac3a3b572f009e4c0ed9e53ee967e2129dbf88cb2052cb8862cdb541f676ff2fb6a719c825928ff4760 SHA512 b40c2248c900c70f1b6603fd5d607005e07ce1278d4dacf72dd6664f7558a3b382ec815cd9215dd17f5b69a09002d48fa9e960771b274fb1fb08dfa4daf9df2a
AUX binaryornot-0.4.4-tests.patch 674 BLAKE2B f07730709f11bf0732b60b81603c40bea1fa6da2d8df545b088072e0f710a7e123e438b03d2390122b6000c14343e932b38d4b6f8956ea87b72e29deae1a4715 SHA512 8a0f1066a580f08778434ed7d30c2ebf2764dbfd746b561ffce2fb8dd8d77cafaf4a58b03504cf5b1e4d37e0a6ffe3038dcaa5611cdfd7d42ada86edd1e47f3f
DIST binaryornot-0.4.4.tar.gz 372361 BLAKE2B cb2099313f602915bacd5b463642f16430fcb0ab62dcaae546cb854780996526fb777c0b730b4b89e664ec7f995ddd2d2f632cfbac2dadca45958cfd1dd7a410 SHA512 31dfb79bb5847e12487d94519a357dece4572f7ed064686d53a49c2de5a51d6441be64523c98cca6221ed89be5bf26e54866dd3b79ac8d89fd5019a5b4d75a45
+EBUILD binaryornot-0.4.4-r1.ebuild 869 BLAKE2B 337bb810d41ba5267574545058a83862b863e5371fda50a5949e3fcee40722a2ab59296d391244c45ac5988fecf3781b4f6b31b1a69ea09df7aefb9ca01d90ef SHA512 4974d5a1413451bbf5815f7260dae710e2c1462a25d873233509e9169b660ef238592ca05d06247abf25829a7dca8bb868577ecb3eb1214decbd23426e00952a
EBUILD binaryornot-0.4.4.ebuild 768 BLAKE2B e33987a9b4ff8eaf6f53487290b9c9209a242ba7c184f1242c50b2951e0fdc92a7fd5028d166cc6361c9e45c0c9fa95d5600b22cd44525746fc62350bd6830c3 SHA512 aa2fb3ca6efb3864daa55e7040dd634b53ff071d084657e93cf591aadcb87325c433f9f2b91b0d4072875e0754e78ed34146908e639ac020afe1cda79da38aaf
MISC metadata.xml 324 BLAKE2B 85a0925b2255a6577beed4974beba21884b88df30bc1519f6ce16e856659589c6e6e38166540f59fb0043885ce786382d90b6830c6ed1bc0051a5d728a1f780b SHA512 f20343e29c9a1d2bb354ecb3c308d5b21985deed5368d27dc144c3a6f2e236f30f7516e27a56e55be48fda32bd59ae9af96ff3b90ecf641bf57dc5b61a4267c6
diff --git a/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild b/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..b9ce949a9e5d
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="https://github.com/audreyr/binaryornot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+PATCHES=(
+ # https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
+ "${FILESDIR}"/${P}-tests.patch
+ # Version number has not been updated to 0.4.4
+ "${FILESDIR}"/${P}-fix-version-number.patch
+)
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs
diff --git a/dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch b/dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch
new file mode 100644
index 000000000000..05d6ed0b7449
--- /dev/null
+++ b/dev-python/binaryornot/files/binaryornot-0.4.4-fix-version-number.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 68a4f5b..a0c9e14 100755
+--- a/setup.py
++++ b/setup.py
+@@ -13,7 +13,7 @@ with open('README.rst') as readme_file:
+ with open('HISTORY.rst') as history_file:
+ history = history_file.read().replace('.. :changelog:', '')
+
+-version = '0.4.3'
++version = '0.4.4'
+
+ if sys.argv[-1] == 'publish':
+ os.system('python setup.py sdist bdist_wheel upload')