summaryrefslogtreecommitdiff
path: root/dev-python/binaryornot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 21:05:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 21:05:47 +0000
commit60f657b5e6155f26601c7def7baa11cee72246d0 (patch)
tree25aecda1c8de352c03f653934407abebf384a560 /dev-python/binaryornot
parente523ebcd50638ebe53f8f425d126bfa7385703b5 (diff)
gentoo auto-resync : 01:02:2023 - 21:05:47
Diffstat (limited to 'dev-python/binaryornot')
-rw-r--r--dev-python/binaryornot/Manifest1
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4-r3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/binaryornot/Manifest b/dev-python/binaryornot/Manifest
index 270cc4d1890c..5e96e8d6634a 100644
--- a/dev-python/binaryornot/Manifest
+++ b/dev-python/binaryornot/Manifest
@@ -1,4 +1,5 @@
AUX binaryornot-0.4.4-tests.patch 674 BLAKE2B f07730709f11bf0732b60b81603c40bea1fa6da2d8df545b088072e0f710a7e123e438b03d2390122b6000c14343e932b38d4b6f8956ea87b72e29deae1a4715 SHA512 8a0f1066a580f08778434ed7d30c2ebf2764dbfd746b561ffce2fb8dd8d77cafaf4a58b03504cf5b1e4d37e0a6ffe3038dcaa5611cdfd7d42ada86edd1e47f3f
DIST binaryornot-0.4.4.r1.tar.gz 371054 BLAKE2B 4a70e22eba51a266987308e8d1b4571ace5760f945920194a1a61f4336f33dcb655c4f0b1f760aa3502834d29a1a64ac62657e5d73eac8f1d7d02edf71db8af9 SHA512 379e71b41824b9389ea02c64223e26c57694d07b749c197e3a6b9f10558c8d502e9b93a13ae6c3a4bca49064ffc650ce822073dc312fb06e50e06b8a3f04f419
EBUILD binaryornot-0.4.4-r2.ebuild 812 BLAKE2B f44f6f3b5c56c1fcf95cf9f48d1e194a7d8230c0efb8294c6943baf8c99bde1a678cc242287ebe9e24d748504d7cc0433bee9a816dbfc884a5ab620b9152650a SHA512 7b7a19aa60d0598d37b1aebe36b5c86762f46f9af4ba8a759748d828c6222477619ea6beb985e68726735f6ec89d6e470c0958419b6f0aee343d805be4a44cab
+EBUILD binaryornot-0.4.4-r3.ebuild 898 BLAKE2B 57b6e4722f0e21b93467f62e84076f5c5b10937a60349cfcb3009ba9c76382745ec870d70658c6153aea150b99e04359de2589a282718e310c011ab85993ca88 SHA512 7b01c25ef9a4931a71aa731c9f5bf067b4f565606a1ee6ecb9c2aeaabc11bc905e516405810f16809a481ce52de9a532c4e112a78901b544d2b723dcd6dd5f6b
MISC metadata.xml 404 BLAKE2B ee81a7d43719ea7ca5819ca53ba0ee32d84372b08af7f3716f2dab221bd26c5d922d8da1956bd3aaefe292bdc3ee8a077c09ea93c0f8ca6d2270a6def5c0b6b3 SHA512 7bf005480a3bcd7d13d28735b73a13bdd96107b11da7bf06bfc2894f2f2c514a72f946bab4b8ff4cd8f8dad651b96ea68566e712b77aa506d258c11d5390d25b
diff --git a/dev-python/binaryornot/binaryornot-0.4.4-r3.ebuild b/dev-python/binaryornot/binaryornot-0.4.4-r3.ebuild
new file mode 100644
index 000000000000..77d3e22aa76c
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.4-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="
+ https://github.com/audreyfeldroy/binaryornot/
+ https://pypi.org/project/binaryornot/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.r1.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+PATCHES=(
+ # https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
+ "${FILESDIR}"/${P}-tests.patch
+)
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs