summaryrefslogtreecommitdiff
path: root/dev-python/binaryornot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/binaryornot
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/binaryornot')
-rw-r--r--dev-python/binaryornot/Manifest3
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4.ebuild28
-rw-r--r--dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch22
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/binaryornot/Manifest b/dev-python/binaryornot/Manifest
index d67d0c29f58c..8674e3e57cf0 100644
--- a/dev-python/binaryornot/Manifest
+++ b/dev-python/binaryornot/Manifest
@@ -1,3 +1,6 @@
+AUX binaryornot-0.4.4-tests.patch 674 BLAKE2B f07730709f11bf0732b60b81603c40bea1fa6da2d8df545b088072e0f710a7e123e438b03d2390122b6000c14343e932b38d4b6f8956ea87b72e29deae1a4715 SHA512 8a0f1066a580f08778434ed7d30c2ebf2764dbfd746b561ffce2fb8dd8d77cafaf4a58b03504cf5b1e4d37e0a6ffe3038dcaa5611cdfd7d42ada86edd1e47f3f
DIST binaryornot-0.4.3.tar.gz 372299 BLAKE2B c4ae99b9ccb66da8925d74fad68b8df4713822acc74d852e2f584e5c157eb465bc6418b0e0085533479ba1ee937c3d2716dea66ce3bd517d49a490ab4615f694 SHA512 bdb918b921fc46d056572b84126dbdc6605ec98cf13aac84f6f64ce07d083839be40bf7a08185eaabfbe136a9bcf0c1acc8041a23a6bb2843e8e72981222ebaa
+DIST binaryornot-0.4.4.tar.gz 372361 BLAKE2B cb2099313f602915bacd5b463642f16430fcb0ab62dcaae546cb854780996526fb777c0b730b4b89e664ec7f995ddd2d2f632cfbac2dadca45958cfd1dd7a410 SHA512 31dfb79bb5847e12487d94519a357dece4572f7ed064686d53a49c2de5a51d6441be64523c98cca6221ed89be5bf26e54866dd3b79ac8d89fd5019a5b4d75a45
EBUILD binaryornot-0.4.3.ebuild 686 BLAKE2B 675aa23764e7fa1122aa9524d29ef359615d1263f4e48666ef91638badbe5aaad193d64ab769dfcd8ffc5525e0b0cb66f8193ee0ebdb0bb31118c6de06d3abf8 SHA512 9a6eb7550bba8df5f12233b3833191f7e816713c7374bdc9367b0c1017dd4fe75a49c12546126b97c14031f12f60584c7d82c8343055b9b90d3519c6d4e96392
+EBUILD binaryornot-0.4.4.ebuild 769 BLAKE2B 6431ccb001c72fc6463b5c7398a745da268ba48ff9492c0aba59696fb8957f9638adf600608d14be58b91b232dcf0cc5c33ca4a59c98ca778046e0ef9e107dae SHA512 662b6fc55212767383bc3fc7c967ed5d0464d80670e0b8ab8300d55520fdb114477bc37560ea0e6d9acc04831b81594afdcff46e9c178beb8031f6628a458d91
MISC metadata.xml 324 BLAKE2B 85a0925b2255a6577beed4974beba21884b88df30bc1519f6ce16e856659589c6e6e38166540f59fb0043885ce786382d90b6830c6ed1bc0051a5d728a1f780b SHA512 f20343e29c9a1d2bb354ecb3c308d5b21985deed5368d27dc144c3a6f2e236f30f7516e27a56e55be48fda32bd59ae9af96ff3b90ecf641bf57dc5b61a4267c6
diff --git a/dev-python/binaryornot/binaryornot-0.4.4.ebuild b/dev-python/binaryornot/binaryornot-0.4.4.ebuild
new file mode 100644
index 000000000000..ec80214fe93e
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="https://github.com/audreyr/binaryornot"
+SRC_URI="https://github.com/audreyr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+PATCHES=(
+ # https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
+ "${FILESDIR}"/${P}-tests.patch
+)
+
+distutils_enable_tests unittest
diff --git a/dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch b/dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch
new file mode 100644
index 000000000000..2070485b6a0d
--- /dev/null
+++ b/dev-python/binaryornot/files/binaryornot-0.4.4-tests.patch
@@ -0,0 +1,22 @@
+From 38dee57986c6679d9936a1da6f6c8182da3734f8 Mon Sep 17 00:00:00 2001
+From: Greg <gregobinna@gmail.com>
+Date: Sat, 10 Aug 2019 15:10:33 +0000
+Subject: [PATCH] fix failing test
+
+---
+ tests/test_check.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_check.py b/tests/test_check.py
+index 1ea31a4..f800583 100755
+--- a/tests/test_check.py
++++ b/tests/test_check.py
+@@ -216,7 +216,7 @@ def bytes_in_file(data):
+
+
+ class TestDetectionProperties(unittest.TestCase):
+- @given(binary(average_size=512))
++ @given(binary(max_size=512))
+ def test_never_crashes(self, data):
+ with bytes_in_file(data) as f:
+ is_binary(f)