summaryrefslogtreecommitdiff
path: root/dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild')
-rw-r--r--dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild b/dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild
new file mode 100644
index 000000000000..f53260760261
--- /dev/null
+++ b/dev-python/binaryornot/binaryornot-0.4.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra-lightweight pure Python package to guess whether a file is binary or text"
+HOMEPAGE="https://github.com/audreyfeldroy/binaryornot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.r1.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND=">=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+PATCHES=(
+ # https://github.com/audreyr/binaryornot/commit/38dee57986c6679d9936a1da6f6c8182da3734f8
+ "${FILESDIR}"/${P}-tests.patch
+)
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs