summaryrefslogtreecommitdiff
path: root/dev-python/betamax/betamax-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/betamax/betamax-0.8.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/betamax/betamax-0.8.0.ebuild')
-rw-r--r--dev-python/betamax/betamax-0.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/betamax/betamax-0.8.0.ebuild b/dev-python/betamax/betamax-0.8.0.ebuild
new file mode 100644
index 000000000000..e39b5dd1f255
--- /dev/null
+++ b/dev-python/betamax/betamax-0.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="python-requests HTTP exchanges recorder"
+HOMEPAGE="https://github.com/sigmavirus24/betamax"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+
+# Tests require Internet access
+RESTRICT=test
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}