summaryrefslogtreecommitdiff
path: root/dev-python/behave
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/behave
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/behave')
-rw-r--r--dev-python/behave/Manifest3
-rw-r--r--dev-python/behave/behave-1.2.5-r1.ebuild49
-rw-r--r--dev-python/behave/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/behave/Manifest b/dev-python/behave/Manifest
new file mode 100644
index 000000000000..56a30912a4ca
--- /dev/null
+++ b/dev-python/behave/Manifest
@@ -0,0 +1,3 @@
+DIST behave-1.2.5.tar.gz 385738 BLAKE2B 0474d6442339ea263cbbc58a3d4ce86bd576d3b4a9e46cc14ebf9b722a07c4d85f7203791bab427188d24ffc75b92011dac3c967503177cae4e0d26d25d171c2 SHA512 137ede0baed9df154087249df8dcae81ab0cdf1de91a5790fca7ccf3231ba2ba4e64623abd2b8c9bfc459ab6575f68b9ef7e03e33ef79e524d9443a8489ec7fe
+EBUILD behave-1.2.5-r1.ebuild 1414 BLAKE2B 56364e8e5ef804e4652cddf53666c28f11fdc54c8cb8af31fe41c9ac27672f5769ae8b8089d13a0c054d102762f77d7bb5990e99371e374b22a1fa59f98fabd7 SHA512 4df654925fe6788670b8bfe19697e2afdccda9b6a63a2925928949012775a9efb71a14fd3e91c59a2bb0e9e6fbc69f7dd51c995d28837b18badb1485cc506655
+MISC metadata.xml 261 BLAKE2B 36c9f189064357614d9be7714f08b4bf3616226e65ba0b571839897873ac629d6432b3ea89bcb896b11f1d2d7e335247c5356b5a5daaf45ffc01cb8ba5f3e43e SHA512 2fb363da61f79ff9d647644f210b3aa8d0ca307510816318f69b91c07a9ca6a0de5b23452ebf82cfff5b518c8314c8f94cfd116cc22f1b67ff949e63fd46ea09
diff --git a/dev-python/behave/behave-1.2.5-r1.ebuild b/dev-python/behave/behave-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..1ec6a477f641
--- /dev/null
+++ b/dev-python/behave/behave-1.2.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="behaviour-driven development, Python style"
+HOMEPAGE="https://github.com/behave/behave"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/parse-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/parse-type-0.3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-cheeseshop-0.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.8[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "nosetests failed under ${EPYTHON}"
+
+ ${PYTHON} -m behave --tags='~@xfail' features/ || die "behave features failed under ${EPYTHON}"
+ ${PYTHON} -m behave --tags='~@xfail' tools/test-features/ || die "behave test-festures failed under ${EPYTHON}"
+ ${PYTHON} -m behave --tags='~@xfail' issue.features/ || die "behave issue.features failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/docs/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/behave/metadata.xml b/dev-python/behave/metadata.xml
new file mode 100644
index 000000000000..c8179e523f89
--- /dev/null
+++ b/dev-python/behave/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">behave</remote-id>
+ <remote-id type="github">behave/behave</remote-id>
+ </upstream>
+</pkgmetadata>