summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/beautifulsoup
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/Manifest7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild28
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild46
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.6.0.ebuild45
-rw-r--r--dev-python/beautifulsoup/metadata.xml19
5 files changed, 145 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
new file mode 100644
index 000000000000..11c709a35de6
--- /dev/null
+++ b/dev-python/beautifulsoup/Manifest
@@ -0,0 +1,7 @@
+DIST BeautifulSoup-3.2.1.tar.gz 31224 BLAKE2B 9361ce6d048d0443c3257d10ec2734c24202af8eb850a59a4344e6992856f849d92dd509f102c27cdf9634bbc235e5f96e304993e6d4813d275d66bd3791b451 SHA512 365b7b045a2069cf437877543577bc0aa99256a6dc4c9743670b46bfceab5494a06628012d6eccecfe99c25d5c9e0c65814964b47026f15ba1a538444cfb7789
+DIST beautifulsoup4-4.5.1.tar.gz 158039 BLAKE2B 5eb99c7efdb13c359385c7c7f3280332ca28cc4b5ff80b90c326d80ef55acef8e98d86691a7b1df420bf68bc65e96ad7d559b461a03f44e494fb4b7789753601 SHA512 d560d7f743507084ec546708d29bb3764512f5b2c380004280dde813350bf48d1697fddce3bd3f95186407bf5142941d7adc7d0de8e7962eb5ca1278dbc7e93f
+DIST beautifulsoup4-4.6.0.tar.gz 160846 BLAKE2B c56c61c5ac2116721815b3cc8e0ec249f191a76bc36e26593af54cc0937e3a4d70c5a2b3069b12f1ae4f5b78cda78e2abda5da99fdd6987afe0f581a4130685c SHA512 1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578
+EBUILD beautifulsoup-3.2.1-r1.ebuild 858 BLAKE2B d8a3a865e18101053361a4be6d569344484317891f1611d8a3ce2d168a8e4eb0d6b28fb067fb1cb74cc57fa89d99da7c50f6edd37bc120232a51e5962d6eadb9 SHA512 879c787894a065f4150c8b6021ff30f15ee0d273de06c0d151ef84157eee1e5d2ca56df9104ac8a6a44d43cb332d3367cc8f2861b7324d851f0285e1c7e174ad
+EBUILD beautifulsoup-4.5.1.ebuild 1359 BLAKE2B 7629a7dd000b55c72fdf523e361be3756c290a478eda10e20cec96e7725d15082125755ab28fda3c79d1b8f1500f4f6aecb832af93db4077a9ca68eaae37383a SHA512 334927959ed9a41f0bb9b7deea78481504d0051801eab94a66981d3ca3fe5dc69f953dcdb46294a9f68177031b3571b9efed3cf9bff598072d4a1eeb6087bf61
+EBUILD beautifulsoup-4.6.0.ebuild 1328 BLAKE2B 3f649ae6a510b8a9d536520a478bbcea5ca9765ee243de57dcad00a99deee166d83d3eac8e1cc0cea51a5febc165858db6f0f7ad03eba4495637a1d609454b67 SHA512 c137297c90c50c200b3d493b82f661e8bd7c9c100a898a43ce198100b0adaaa327c6b2e29f3d2b7fe4ea302026df4ddde4ac6696fa6fa5a08e06fade2f4492c2
+MISC metadata.xml 720 BLAKE2B eb5a827491cd19df36bee9593e3e110a986fceee9f6d62a4de47edfc3daf4e1090062a2a9a4c8bc9cbb4f9b378de0c21126b3229740b7e75fba22643fb28fbcd SHA512 94493d30b0e0e55b94d08f9a56841c54088469a86b706b73e8efe9c0f9a0da598feececd01f5f14d7e28bfe6fea5d7b017fb84a2df680335f519803450c6f578
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..46cd66be7bb2
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.2.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/ https://pypi.org/project/BeautifulSoup/"
+SRC_URI="https://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="python-2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" BeautifulSoupTests.py || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild
new file mode 100644
index 000000000000..84f52ff0e4bd
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://bugs.launchpad.net/beautifulsoup/
+ https://pypi.org/project/beautifulsoup4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.6.0.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.6.0.ebuild
new file mode 100644
index 000000000000..b1e9315a545a
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/beautifulsoup/metadata.xml b/dev-python/beautifulsoup/metadata.xml
new file mode 100644
index 000000000000..1a865dd3b27d
--- /dev/null
+++ b/dev-python/beautifulsoup/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Beautiful Soup is a Python HTML/XML parser designed for quick
+ turnaround projects like screen-scraping. Two features make it
+ powerful: it won't choke if you give it bad markup and it provides a
+ few simple methods and Pythonic idioms for navigating and searching
+ a parse tree: a toolkit for dissecting a document and extracting
+ what you need.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">beautifulsoup4</remote-id>
+ </upstream>
+</pkgmetadata>