summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
commitd36c5f9e59f92a021c987989cd79d44460e0da42 (patch)
tree2504c88d1f287ac3a71ebc56e5d19f34a2c1b9a4 /dev-python/beautifulsoup4
parente860dfa5acdb67f8e2b8938b005dbaaaaf2c984a (diff)
gentoo auto-resync : 31:01:2023 - 21:02:55
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest2
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.11.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 852afc2f3aeb..b2b75718ceaf 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,3 +1,5 @@
DIST beautifulsoup4-4.11.1.tar.gz 517113 BLAKE2B bc0cc8dbb1bffca2d3441a274147f201b79447f2147f7b4c329f05f6d230f9986eebd3709199d0b3c7dba8c15e4ce42e9dc75e290a2bfdfdae643f5dfe07e767 SHA512 7446be07cd55f23def929e6491f0d74a940cf50206ed520b8ae7b9d57bd19ecf6aa821f446ca4f26f1e08b43fcc71fb397886f51a3f0ec691f9e53dfdc7a0cf8
+DIST beautifulsoup4-4.11.2.tar.gz 517627 BLAKE2B 19fc88dff84c398461ecce3b66b1a92c3541114e3595aa1bae7182914e174d9c36b6de37ba120200695f6dca489c6afcd361244ae9577bc469d20a0864989d48 SHA512 68f5328f881946e80ed1af36b26da184f0af58aaf124f5f623f89c40130e1578f6dbe874b11c802e52c0ec02cfbf6b681e10eb235279631f479d14c2243e7dd3
EBUILD beautifulsoup4-4.11.1.ebuild 1023 BLAKE2B 7ceb6f5973ee8977e2b6e42f3cdc56aef5f39475a450f8b3474ba26cd1a76ffba8955105d27140466d8070071b484cfcbbcd3e9b02ceaada3783d4997a10a89a SHA512 9ed6ecc27795d65c35cf0eeffdd5281551013ea8f3daa648755f2212e55226ed717e4c958b284ad4c597ef20592a693ba1505edd381ce4377faade931516bb07
+EBUILD beautifulsoup4-4.11.2.ebuild 1031 BLAKE2B 26eb1d41cd4e657576be1bd3e9566713dcdf16c1e8baaff96a4388e8781c10ca71ee1e99e87a288994b733abc0b514d83858c37a42a7aabf7abff3586b28f2a3 SHA512 5d8efead2a470e7def255619fa494663cf7812e48dbc08fb1de4dbec1abcb9b36eca687f3b8f362bd2bc60998ff8b7547e3a20e9b616bec3e93dd713c0e98520
MISC metadata.xml 745 BLAKE2B 16e44221decda568bcfd7fc64384f3c10d6150801bd099fbee3abb0273fa53bc83494cd9a56d43b125e9b2d773f9e1dcd35820bcc26a28048beea287a9fc3e23 SHA512 b332203a23fbeef550ce75c70afcf6eb9decf4e3e0409899d556e4e12449608100e1e6af81f163a879937bea2726195524559aa1151f917cc9facdf2bde559e0
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.11.2.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.11.2.ebuild
new file mode 100644
index 000000000000..a785ef80106c
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.11.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source