summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
commit88a7ab8599213acca9dd34eb21748ff54d7c190a (patch)
tree7b0906984ae3d3754da31f07f7c730f719d2f92a /dev-python/beautifulsoup4
parent942c9977e0273ee6c6bd3f9822263aaeab1b69a5 (diff)
gentoo auto-resync : 18:01:2024 - 08:07:22
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest2
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 958999a4caef..e6401453953c 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,3 +1,5 @@
DIST beautifulsoup4-4.12.2.tar.gz 505113 BLAKE2B 94412a87dcffeb14655417eb61a784c8933aea79c81721ebf30114d55fd3e0f58850e0cfed354d3573d1bf18b556f3d83474b64a2a8d88f503c5125d5931321d SHA512 1dbb620f675bb319ef050ece0f343e80359bdc59cd8b8de19b1851aa5bca1081a7e953e3221ad97142198c17f67384c05b0406af24a123d71398f209fb89db97
+DIST beautifulsoup4-4.12.3.tar.gz 581181 BLAKE2B dac85b2d56ad1d2faf040def2141cb7a7ca68def7fc48fab18e11c23878795fcecfdd43058e70229e014e23e67f56a55160aa4ba08bab4b3d955bd10a07c8168 SHA512 b5b6cc9f64a97fa52b9a2ee1265aa215db476e705d3d79e49301de7e8d36c56c96924cb440eec0715f7ec75c5ddf4c1ade9d6cef7cdc9bf9e37125ac6eb50837
EBUILD beautifulsoup4-4.12.2.ebuild 983 BLAKE2B ff88e31bcb9008ba64493a99d9c97bc918207f37509428ec36705bf6e79eee4987ec1c25b89def894bfeb283853bf4d827a990be4d8f5d4234d67b4fb41096fc SHA512 86e2b5695f14229d80aa07a622587da87f9d8ca9cc373e7f9d499d886b86bd030be68f347600215b8601d3912e7a6dbfcde786dd204007ed1b1a8e5772316b60
+EBUILD beautifulsoup4-4.12.3.ebuild 1036 BLAKE2B 57816235ff8295eec0ef7c1aeab07b1edf91cc47468166f1e7093ee492d83b65760ea4786805ea50197bfe63da318e978c3613d5a0f6f5c927d8924747f8864c SHA512 f968f540ea09a0bb07e81d4348348a109d67c65ffe8b53ff6fae6fac9ef2216161120a932012c85aca2057a729e147138eeb778f0f4ce70807076313c0c88035
MISC metadata.xml 745 BLAKE2B 16e44221decda568bcfd7fc64384f3c10d6150801bd099fbee3abb0273fa53bc83494cd9a56d43b125e9b2d773f9e1dcd35820bcc26a28048beea287a9fc3e23 SHA512 b332203a23fbeef550ce75c70afcf6eb9decf4e3e0409899d556e4e12449608100e1e6af81f163a879937bea2726195524559aa1151f917cc9facdf2bde559e0
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild
new file mode 100644
index 000000000000..784eac739f5f
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.12.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="
+ https://www.crummy.com/software/BeautifulSoup/bs4/
+ https://pypi.org/project/beautifulsoup4/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/soupsieve-1.3[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source