summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/beautifulsoup4
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest5
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild24
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild32
-rw-r--r--dev-python/beautifulsoup4/metadata.xml20
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
new file mode 100644
index 000000000000..46be1bc4b705
--- /dev/null
+++ b/dev-python/beautifulsoup4/Manifest
@@ -0,0 +1,5 @@
+DIST beautifulsoup4-4.10.0.tar.gz 399890 BLAKE2B 61f044064a81e94b64a72fd49cca164faa05442bc76f897c8a7fa4481acca039bcb9e4f7a1853a7155504fa25e56c518806d8af016369bc37316ecb95b59d7d3 SHA512 92be99ed0fd479b86519395143516e28f7b80f54a8251223d6e7b88dc98f8dfca9585079f5f1d89bfe68f577de3dff433711642486303203f46bc76754959a18
+DIST beautifulsoup4-4.9.3.tar.gz 376031 BLAKE2B fbe2139f288eee978c3f665c7640f66c6c51b857a186f6a8ace02b36effa1552f1cbea9e3744e0a46a65a06e6cdbd9203832e0ecd86b61406b933f9bd83d37b8 SHA512 e3cb6258bd7c51f12128fa8ee5948fb3566163ae233fac2dda21bab7772ab8dbb384d920b0ea138ef9921307b48f89cee3a9bf6111dfc8903d917ee7af365f34
+EBUILD beautifulsoup4-4.10.0.ebuild 703 BLAKE2B e884b319e983243d2c453e33ee518ce9a7b0d86e0e937f21b01871d51fdd5b4f0841d248315c722a466a366beb453f088f0bb80f5157096516ea781b6ec9b6a3 SHA512 d2ee8d00edd2813a55ab26983bea741390489d026ee0f4bb26e6810ce2b173b5277d556b76d5ab4c8775898030a2ab80050a5b2214d9c609ab8b15f871d591b1
+EBUILD beautifulsoup4-4.9.3.ebuild 847 BLAKE2B efd71a4c1d8cb5229f7ae59dbc17b54b1e10a4a5a922a1544c8a97b5baa6a9df3c4b6f795b36cb48593e7b2ceaf0ec52e84a5d2f8f3311852acf75dca37c47bf SHA512 46c54efec8bead03640391dc71e58812dd5e5ae91ed63cb3f30f91e8853e3eb8f91528f2b41ebbea1bb0f08694b4e1a53383003bae7bc4840510088249b6ed3f
+MISC metadata.xml 744 BLAKE2B 93987e4adb8dc5dea9b897940cae80d431b29d693bd1fea9d242de75174b1fd86afaecc6a5fb5e4ad06576caa559a918d09da28d253147f2683703d911435f76 SHA512 f56ab7ff03d21187e38f292b24396eccfd53622c84f5f489bd1e515393dbf85b75bbdfe26a6875352b16dcbf16f89cd9a051dfe44dbca8786efecd7db914f789
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
new file mode 100644
index 000000000000..975d9e35d6bd
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx doc/source
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
new file mode 100644
index 000000000000..c9b54e80fbf0
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ <dev-python/setuptools-58[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/beautifulsoup4/metadata.xml b/dev-python/beautifulsoup4/metadata.xml
new file mode 100644
index 000000000000..227205f32598
--- /dev/null
+++ b/dev-python/beautifulsoup4/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Beautiful Soup is a Python HTML/XML parser designed for quick
+ turnaround projects like screen-scraping. Two features make it
+ powerful: it won't choke if you give it bad markup and it provides a
+ few simple methods and Pythonic idioms for navigating and searching
+ a parse tree: a toolkit for dissecting a document and extracting
+ what you need.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">beautifulsoup4</remote-id>
+ </upstream>
+</pkgmetadata>