summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-06 00:10:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-06 00:10:59 +0000
commit22eaa60297c2dbc92dd1658fb7d8e46878552755 (patch)
treec3e1147cecf778a6418d736658cedc5d7f2dfa2d /dev-python/beautifulsoup4
parente019d91362a4788fe5cc5788877327b813d0f730 (diff)
gentoo auto-resync : 06:02:2025 - 00:10:59
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest2
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.13.3.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 74774c7b68b1..c26b0b7df204 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1,5 +1,7 @@
DIST beautifulsoup4-4.12.3.tar.gz 581181 BLAKE2B dac85b2d56ad1d2faf040def2141cb7a7ca68def7fc48fab18e11c23878795fcecfdd43058e70229e014e23e67f56a55160aa4ba08bab4b3d955bd10a07c8168 SHA512 b5b6cc9f64a97fa52b9a2ee1265aa215db476e705d3d79e49301de7e8d36c56c96924cb440eec0715f7ec75c5ddf4c1ade9d6cef7cdc9bf9e37125ac6eb50837
DIST beautifulsoup4-4.13.1.tar.gz 618295 BLAKE2B 4573920d2eeb53e0b4ae2ff9f0f7152a9209fbe79c1bf5ca894289759f5802a550a965016e16f731990e0be1a0dc343593a40720f18219ca1b834a7e49ffe91c SHA512 f661966c9c4a1e0ea3141b8c926ad9ffa010fb2ae48e2715c57812fca09d8a5434128f289a5bbc7a277ffc0b7925c7bc7c6c59c52e3126a926b06e74cc091a09
+DIST beautifulsoup4-4.13.3.tar.gz 619516 BLAKE2B f7fc24efe3a107b063b985888481e851ff73e1a1b672701af7846cab6d7ba550339111c0c0b6928656f034561a33e264bf3cfa5c0f097eb6c64a9b46a795fcb6 SHA512 44cc938e5f981be0deeba864ed44460bcf37e8cdc1c1732fc948d3bc310b1b1008817a63794eb650165d7b56eda6d668ab0e16bcc5dd3ffcecbd932f743d48c1
EBUILD beautifulsoup4-4.12.3.ebuild 1028 BLAKE2B d4d2262ab8edf41437ce0e7d5245c8543e0f2f4cd79f468c7c51cbf07936b2c6242ef7b6e44477435b1f9486657e5334b10ea4c41674345afda030f0753d0ed8 SHA512 102e4c2273b6780bc7514e6ec5afdfae16541f4b00a6528043464189f6dbab2242de9f849fbb5838c57ee9dfdaa8bbf6f051610b48614b9a79f8fc9ebafe8cd4
EBUILD beautifulsoup4-4.13.1.ebuild 1126 BLAKE2B 7e9f53035de7d4ddd4e6ff04005cfd6aea3033348ef9115dce8ffdb3f3758656e58c7bccfdb35822d30b8c717c637487af9bac0a93092134eefe44f72a936776 SHA512 2fa504f56c05196472e45751c99f70dd4186119fe89934ea055489bcd4d1dbdadc5b3d0099bdfc434f50f0c87012814ffe2f8478e8b6c8e578f4215906eabd82
+EBUILD beautifulsoup4-4.13.3.ebuild 1126 BLAKE2B 7e9f53035de7d4ddd4e6ff04005cfd6aea3033348ef9115dce8ffdb3f3758656e58c7bccfdb35822d30b8c717c637487af9bac0a93092134eefe44f72a936776 SHA512 2fa504f56c05196472e45751c99f70dd4186119fe89934ea055489bcd4d1dbdadc5b3d0099bdfc434f50f0c87012814ffe2f8478e8b6c8e578f4215906eabd82
MISC metadata.xml 745 BLAKE2B 16e44221decda568bcfd7fc64384f3c10d6150801bd099fbee3abb0273fa53bc83494cd9a56d43b125e9b2d773f9e1dcd35820bcc26a28048beea287a9fc3e23 SHA512 b332203a23fbeef550ce75c70afcf6eb9decf4e3e0409899d556e4e12449608100e1e6af81f163a879937bea2726195524559aa1151f917cc9facdf2bde559e0
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.13.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.13.3.ebuild
new file mode 100644
index 000000000000..dc5f09a5c8a7
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.13.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="
+ https://www.crummy.com/software/BeautifulSoup/bs4/
+ https://pypi.org/project/beautifulsoup4/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/soupsieve-2.6[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/faust-cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc